summaryrefslogtreecommitdiffstats
path: root/development/qt-creator/qt-creator.SlackBuild
diff options
context:
space:
mode:
author Andre Barboza2010-05-13 00:25:26 +0200
committer David Somero2010-05-13 00:25:26 +0200
commit5acf20e2a16a2c5a22481a90c58394b95832286e (patch)
tree9c8f0a40f486bc7cda3b76b3d97ce238255d4efa /development/qt-creator/qt-creator.SlackBuild
parent47d63a92821782d9bcdd2a1affc7f3fc73058700 (diff)
downloadslackbuilds-5acf20e2a16a2c5a22481a90c58394b95832286e.tar.gz
development/qt-creator: Updated for version 1.2.1
Diffstat (limited to 'development/qt-creator/qt-creator.SlackBuild')
-rw-r--r--development/qt-creator/qt-creator.SlackBuild44
1 files changed, 22 insertions, 22 deletions
diff --git a/development/qt-creator/qt-creator.SlackBuild b/development/qt-creator/qt-creator.SlackBuild
index f023e43bb9..430c0d0760 100644
--- a/development/qt-creator/qt-creator.SlackBuild
+++ b/development/qt-creator/qt-creator.SlackBuild
@@ -4,10 +4,10 @@
# Copyright 2009 Andre Barboza
# All rights reserved.
-#
+#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
-#
+#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
@@ -26,23 +26,25 @@
# Modified by the SlackBuilds.org project.
PRGNAM=qt-creator
-VERSION=${VERSION:-1.1.0}
+VERSION=${VERSION:-1.2.1}
ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-QTDIR=${QT4DIR:-$QT4DIR}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
set -e
@@ -60,22 +62,21 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-mkdir build
-cd build
- CFLAGS="$SLKCFLAGS" \
- CXXFLAGS="$SLKCFLAGS" \
- qmake-qt4 ../qtcreator.pro
-
- # qdoc3 must be installed to build docs.
- # if you intend to install docs you should patch qt4
- if [ ! -x /usr/lib/qt4/tools/qdoc3/qdoc3 ]
- then
- patch < $CWD/Makefile.diff
- fi
+# qdoc3 must be installed to build docs.
+# if you intent to install docs you should patch qt4
+if [ ! -x $QT4DIR/tools/qdoc3/qdoc3 ]
+then
+ patch -p0 < $CWD/qt-creator.pro.diff
+fi
- make
- make install INSTALL_ROOT=$PKG/usr
-cd -
+# We are intentionally using an in-source build here,
+# because the out-of-source build was causing errors
+qmake \
+ IDE_LIBRARY_BASENAME="lib$LIBDIRSUFFIX" \
+ QMAKE_CXXFLAGS="$SLKCFLAGS" \
+ qtcreator.pro
+make
+make install INSTALL_ROOT=$PKG/usr
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
@@ -98,5 +99,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
-
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}