summaryrefslogtreecommitdiffstats
path: root/development/pyflakes
diff options
context:
space:
mode:
author LukenShiro2010-05-13 00:58:01 +0200
committer David Somero2010-05-13 00:58:01 +0200
commit6ea014bd674af3c25c479ff4b70f37902febafb2 (patch)
tree16441ed3d36f0b1e154d53997347959ab187f1d6 /development/pyflakes
parent50f74b69e1e5c05e8e66e709064f24fc3712975f (diff)
downloadslackbuilds-6ea014bd674af3c25c479ff4b70f37902febafb2.tar.gz
development/pyflakes: Added to 13.0 repository
Diffstat (limited to 'development/pyflakes')
-rw-r--r--development/pyflakes/README16
-rw-r--r--development/pyflakes/pyflakes.SlackBuild61
-rw-r--r--development/pyflakes/pyflakes.info10
-rw-r--r--development/pyflakes/slack-desc19
4 files changed, 106 insertions, 0 deletions
diff --git a/development/pyflakes/README b/development/pyflakes/README
new file mode 100644
index 0000000000..60e7585433
--- /dev/null
+++ b/development/pyflakes/README
@@ -0,0 +1,16 @@
+PyFlakes a Lint-like tool for Python, like PyChecker. It is focused on
+identifying common errors quickly without executing Python code.
+
+Its primary advantage over PyChecker is that it is fast. You don't have
+to sit around for minutes waiting for the checker to run; it runs on most
+large projects in only a few seconds.
+
+The two primary categories of defects reported by PyFlakes are:
+* Names which are used but not defined or used before they are defined
+* Names which are redefined without having been used
+
+These can each take many forms. For example, PyFlakes will tell you when
+you have forgotten an import, mistyped a variable name, defined two functions
+with the same name, shadowed a variable from another scope, imported a module
+twice, or two different modules with the same name, and so on.
+
diff --git a/development/pyflakes/pyflakes.SlackBuild b/development/pyflakes/pyflakes.SlackBuild
new file mode 100644
index 0000000000..9604a2747d
--- /dev/null
+++ b/development/pyflakes/pyflakes.SlackBuild
@@ -0,0 +1,61 @@
+#!/bin/sh
+
+# Slackware build script for pyflakes
+
+# Copyright 2010 LukenShiro <lukenshiro@ngi.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pyflakes
+VERSION=${VERSION:-0.4.0}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCFILES="PKG-INFO"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+python setup.py build
+python setup.py install --prefix=/usr/ --root=$PKG
+
+# Copy documentation files
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/pyflakes/pyflakes.info b/development/pyflakes/pyflakes.info
new file mode 100644
index 0000000000..d1b512bb5f
--- /dev/null
+++ b/development/pyflakes/pyflakes.info
@@ -0,0 +1,10 @@
+PRGNAM="pyflakes"
+VERSION="0.4.0"
+HOMEPAGE="http://www.divmod.org/trac/wiki/DivmodPyflakes"
+DOWNLOAD="http://pypi.python.org/packages/source/p/pyflakes/pyflakes-0.4.0.tar.gz"
+MD5SUM="630a72510aae8758f48cf60e4fa17176"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="LukenShiro"
+EMAIL="lukenshiro@ngi.it"
+APPROVED="dsomero"
diff --git a/development/pyflakes/slack-desc b/development/pyflakes/slack-desc
new file mode 100644
index 0000000000..7cbf59ab9f
--- /dev/null
+++ b/development/pyflakes/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler--------------------------------------------------------|
+pyflakes: pyflakes (passive checker of Python programs)
+pyflakes:
+pyflakes: Pyflakes is a program to analyze Python programs and detect various
+pyflakes: errors. It works by parsing the source file, not importing it, so it
+pyflakes: is safe to use on modules with side effects. It's also much faster
+pyflakes: passive checker of Python programs.
+pyflakes:
+pyflakes:
+pyflakes:
+pyflakes: Homepage: http://www.divmod.org/trac/wiki/DivmodPyflakes
+pyflakes: