summaryrefslogtreecommitdiffstats
path: root/development/pychecker
diff options
context:
space:
mode:
author LukenShiro2013-11-11 16:13:05 +0100
committer Robby Workman2013-11-11 17:53:36 +0100
commit8a720b7565ebb622a1c75889a9266eb31f3f1305 (patch)
treedee479bddefca7ee732eac31503e5e512e5d34a5 /development/pychecker
parent192892025092432f653c2c3c8f8ccbadc381d7ee (diff)
downloadslackbuilds-8a720b7565ebb622a1c75889a9266eb31f3f1305.tar.gz
various: fixes for new templates (find/fixperms)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'development/pychecker')
-rw-r--r--development/pychecker/pychecker.SlackBuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/development/pychecker/pychecker.SlackBuild b/development/pychecker/pychecker.SlackBuild
index 31ebc7bf94..b864555786 100644
--- a/development/pychecker/pychecker.SlackBuild
+++ b/development/pychecker/pychecker.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pychecker
-# Copyright 2010-2011 LukenShiro <lukenshiro@ngi.it>
+# Copyright 2010-2011 LukenShiro, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=pychecker
VERSION=${VERSION:-0.8.19}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -52,7 +52,11 @@ rm -rf $PRGNAM-$VERSION
tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# setup.py modifications to avoid docfiles' installation in pythondir
sed -i "s|'data_files'|#'data_files'|g" setup.py