summaryrefslogtreecommitdiffstats
path: root/development/jupyter-nbclassic/jupyter-nbclassic.SlackBuild
diff options
context:
space:
mode:
author Matteo Bernardini2024-05-25 07:29:59 +0200
committer Matteo Bernardini2024-05-25 07:29:59 +0200
commit9ff7d8a5a0e322aa9e32765d3624c61a52850e23 (patch)
tree0604e95ab9484b023c4763e22a2f89f6a944d36a /development/jupyter-nbclassic/jupyter-nbclassic.SlackBuild
parentbecba3971a51ea467b5e557a19138ec49f667eed (diff)
downloadslackbuilds-current.tar.gz
20240525.1 global branch merge.current-20240525.1current
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'development/jupyter-nbclassic/jupyter-nbclassic.SlackBuild')
-rw-r--r--development/jupyter-nbclassic/jupyter-nbclassic.SlackBuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/development/jupyter-nbclassic/jupyter-nbclassic.SlackBuild b/development/jupyter-nbclassic/jupyter-nbclassic.SlackBuild
index 104abca582..8e69e7f4bf 100644
--- a/development/jupyter-nbclassic/jupyter-nbclassic.SlackBuild
+++ b/development/jupyter-nbclassic/jupyter-nbclassic.SlackBuild
@@ -78,16 +78,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fix /etc/jupyter path
-sed 's|etc|/etc|' -i setup.cfg
-
-python3 setup.py install --root=$PKG
+python -m build --wheel --no-isolation --skip-dependency-check
+python -m installer --destdir=$PKG dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
# Remove bundled mathjax2; replace with system mathjax2
-PYTHONPATH=$(python3 -c "from sysconfig import get_path; print(get_path('platlib'))")
+PYTHONPATH=$(python3 -c "from sysconfig import get_path; print(get_path('purelib'))")
rm -r $PKG/$PYTHONPATH/nbclassic/static/components/MathJax
ln -sr /usr/share/mathjax2 $PKG/$PYTHONPATH/nbclassic/static/components/MathJax