summaryrefslogtreecommitdiffstats
path: root/development/docutils
diff options
context:
space:
mode:
author Jick Nan2010-05-11 20:00:23 +0200
committer Robby Workman2010-05-11 20:00:23 +0200
commit75bcf7a332a10c3afec2a7321492de93e6bc83a2 (patch)
tree3a30932bda9811719f0b6ffe49e6b41fcda8ee87 /development/docutils
parent935bb4017a05ed484dccf69c76b2adb28052f8b0 (diff)
downloadslackbuilds-75bcf7a332a10c3afec2a7321492de93e6bc83a2.tar.gz
development/docutils: Added to 12.0 repository
Diffstat (limited to 'development/docutils')
-rw-r--r--development/docutils/README6
-rw-r--r--development/docutils/docutils.SlackBuild43
-rw-r--r--development/docutils/docutils.info8
-rw-r--r--development/docutils/slack-desc19
4 files changed, 76 insertions, 0 deletions
diff --git a/development/docutils/README b/development/docutils/README
new file mode 100644
index 0000000000..1160a389f0
--- /dev/null
+++ b/development/docutils/README
@@ -0,0 +1,6 @@
+Docutils (Python Documentation Utilities)
+
+Docutils is a modular system for processing documentation into useful
+formats, such as HTML, XML, and LaTeX. For input Docutils supports
+reStructuredText, an easy-to-read, what-you-see-is-what-you-get plaintext
+markup syntax.
diff --git a/development/docutils/docutils.SlackBuild b/development/docutils/docutils.SlackBuild
new file mode 100644
index 0000000000..7f488ade24
--- /dev/null
+++ b/development/docutils/docutils.SlackBuild
@@ -0,0 +1,43 @@
+#!/bin/sh
+
+# Slackware build script for docutils.
+
+# Written by Jick Nan (jick.nan@gmail.com)
+
+PRGNAM=docutils
+VERSION=snapshot
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+rm -rf $PRGNAM
+tar -xzvf $CWD/$PRGNAM-$VERSION.tgz || exit 1
+cd $PRGNAM || exit 1
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+python setup.py bdist || exit 1
+tar zxvf dist/$PRGNAM-*.linux-i686.tar.gz -C $PKG || exit 1
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG_INFO $PKG/usr/doc/$PRGNAM-$VERSION
+install -m 0644 *.txt $PKG/usr/doc/$PKG_NAME-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/docutils/docutils.info b/development/docutils/docutils.info
new file mode 100644
index 0000000000..cc32cece05
--- /dev/null
+++ b/development/docutils/docutils.info
@@ -0,0 +1,8 @@
+PRGNAM="docutils"
+VERSION="snapshot"
+HOMEPAGE="http://docutils.sourceforge.net/"
+DOWNLOAD="http://docutils.sourceforge.net/docutils-snapshot.tgz"
+MD5SUM="2b93dc97eb14d6ddc77152853fedb85a"
+MAINTAINER="Jick Nan"
+EMAIL="jick.nan@gmail.com"
+APPROVED="rworkman"
diff --git a/development/docutils/slack-desc b/development/docutils/slack-desc
new file mode 100644
index 0000000000..9b15ab9d15
--- /dev/null
+++ b/development/docutils/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+docutils: Docutils (Python Documentation Utilities)
+docutils:
+docutils: Docutils is a modular system for processing documentation into useful
+docutils: formats, such as HTML, XML, and LaTeX. For input Docutils supports
+docutils: reStructuredText, an easy-to-read, what-you-see-is-what-you-get
+docutils: plaintext markup syntax.
+docutils:
+docutils:
+docutils:
+docutils:
+docutils: