summaryrefslogtreecommitdiffstats
path: root/development/Pivy
diff options
context:
space:
mode:
author Heinz Wiesinger2010-05-13 00:06:47 +0200
committer Heinz Wiesinger2010-05-13 00:06:47 +0200
commit101389a7a086ca1016ddc32c5402963eb0af963a (patch)
treed1d3d669685bb726c2b3f40a881a244fd9dc0261 /development/Pivy
parenta808bcd2364517cea14ff7300f2948871cd0f663 (diff)
downloadslackbuilds-101389a7a086ca1016ddc32c5402963eb0af963a.tar.gz
development/Pivy: Removed from 13.0 repository
Diffstat (limited to 'development/Pivy')
-rw-r--r--development/Pivy/Pivy-mksrctarball.sh21
-rw-r--r--development/Pivy/Pivy.SlackBuild61
-rw-r--r--development/Pivy/Pivy.info8
-rw-r--r--development/Pivy/README30
-rw-r--r--development/Pivy/slack-desc19
5 files changed, 0 insertions, 139 deletions
diff --git a/development/Pivy/Pivy-mksrctarball.sh b/development/Pivy/Pivy-mksrctarball.sh
deleted file mode 100644
index bfeaaa161c..0000000000
--- a/development/Pivy/Pivy-mksrctarball.sh
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/bin/sh
-
-# This script helps you to download and compress the sourcecode for
-# Pivy from its svn server.
-
-set -e
-
-PRGNAM=Pivy
-VERSION=$(date +"%Y%m%d")
-SVNSERVER=https://svn.coin3d.org/repos/
-
-echo "--> Downloading sourcecode from $SVNSERVER"
-echo "t" | svn export $SVNSERVER/$PRGNAM/trunk $PRGNAM-$VERSION 2>&1 | tee svn-$PRGNAM-$VERSION.log
-
-echo "--> Making the sourcecode tarball: $PRGNAM-$VERSION.tar.bz2 "
-tar -c $PRGNAM-$VERSION/ | bzip2 > $PRGNAM-$VERSION.tar.bz2
-
-echo "--> Erasing the sourcecode directory: $PRGNAM-$VERSION/"
-rm -rf $PRGNAM-$VERSION/
-
-echo "--> Sourcecode tarball for $PRGNAM: $PRGNAM-$VERSION.tar.bz2"
diff --git a/development/Pivy/Pivy.SlackBuild b/development/Pivy/Pivy.SlackBuild
deleted file mode 100644
index 673dfb31b7..0000000000
--- a/development/Pivy/Pivy.SlackBuild
+++ /dev/null
@@ -1,61 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for Pivy
-
-# Written by Aleksandar Samardzic <asamardzic@gmail.com>
-
-PRGNAM=Pivy
-VERSION=${VERSION:-20081227}
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=${PKG:-$TMP/package-$PRGNAM}
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-python setup.py install --root $PKG
-
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-)
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS ChangeLog HACKING LICENSE NEWS README THANKS \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-find $PKG/usr/doc -type f -exec chmod 0644 {} \;
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/Pivy/Pivy.info b/development/Pivy/Pivy.info
deleted file mode 100644
index 69e0ab7a8f..0000000000
--- a/development/Pivy/Pivy.info
+++ /dev/null
@@ -1,8 +0,0 @@
-PRGNAM="Pivy"
-VERSION="20081227"
-HOMEPAGE="http://pivy.coin3d.org/"
-DOWNLOAD="http://slackbuilds.org/sources/12.2/Pivy-20081227.tar.bz2"
-MD5SUM="24239874972c6ed35cde35d92646c146"
-MAINTAINER="Aleksandar Samardzic"
-EMAIL="asamardzic@gmail.com"
-APPROVED="rworkman"
diff --git a/development/Pivy/README b/development/Pivy/README
deleted file mode 100644
index d16604e664..0000000000
--- a/development/Pivy/README
+++ /dev/null
@@ -1,30 +0,0 @@
-Pivy is a Python binding for Coin where the interface is implemented
-using SWIG.
-
-Pivy allows:
- * development of Coin applications in Python
- * interactive modification of Coin programs from within the Python
- interpreter at runtime
- * incorporation of Scripting Nodes into the scene graph which are
- capable of executing Python code and callback functions
-
-This script is tested using the svn code from 20081227, and this is
-the tarball hosted on our site. You may elect to use this source code
-to build the package, or you can pull the latest from their subversion
-repository as indicated below.
-
-If you want to use the latest subversion source when building your
-Pivy package, you will need to get it from their svn server. To get
-the source code, you can use the included "Pivy-mksrctarball.sh"
-script, which will to download the source code and create a compressed
-tarball of it using the date (date +"%Y%m%d") as its version string.
-
-If you have already Pivy's source code as a tarball, for example:
-Pivy-20081227.tar.bz2
-You can tell the build script to use it with the following command:
-VERSION=20081227 ./Pivy.SlackBuild
-Note that this is the version that will be used by default unless you
-specify otherwise.
-
-Pivy package depends on Coin and SWIG packages, both available from
-SlackBuilds.org.
diff --git a/development/Pivy/slack-desc b/development/Pivy/slack-desc
deleted file mode 100644
index 5a7539595a..0000000000
--- a/development/Pivy/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-Pivy: Pivy (a Coin binding for Python)
-Pivy:
-Pivy: Pivy is an extension to the Python programming language,
-Pivy: wrapping Coin C++ scene graph library for usage from Python.
-Pivy:
-Pivy: Homepage: http://pivy.coin3d.org/
-Pivy:
-Pivy:
-Pivy:
-Pivy:
-Pivy: