summaryrefslogtreecommitdiffstats
path: root/desktop/calcure
diff options
context:
space:
mode:
author Tonus2023-03-06 02:16:26 +0100
committer Willy Sudiarto Raharjo2023-03-12 02:48:31 +0100
commit77233e17e299d242f13788a0a41b95d79aa9e458 (patch)
treed2db50c2ef5add65687b4cf5d90e7e54098406ce /desktop/calcure
parent294b8f605f4a8a5c98a6fabaa96149b08f1c9b2d (diff)
downloadslackbuilds-77233e17e299d242f13788a0a41b95d79aa9e458.tar.gz
desktop/calcure: Added (modern TUI calendar and task manager)
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop/calcure')
-rw-r--r--desktop/calcure/README7
-rw-r--r--desktop/calcure/calcure.SlackBuild95
-rw-r--r--desktop/calcure/calcure.info10
-rw-r--r--desktop/calcure/slack-desc19
4 files changed, 131 insertions, 0 deletions
diff --git a/desktop/calcure/README b/desktop/calcure/README
new file mode 100644
index 0000000000..04ff9ff545
--- /dev/null
+++ b/desktop/calcure/README
@@ -0,0 +1,7 @@
+Calcure is a modern TUI calendar and task manager with customizable
+interface. The program manages your events and tasks, displays
+birthdays from your abook, and can import events and tasks from
+calcurse and taskwarrior.
+
+Be sure to check the wiki, you'll findthere most of what you need
+to know about Calcure.
diff --git a/desktop/calcure/calcure.SlackBuild b/desktop/calcure/calcure.SlackBuild
new file mode 100644
index 0000000000..6e16dbdbd7
--- /dev/null
+++ b/desktop/calcure/calcure.SlackBuild
@@ -0,0 +1,95 @@
+#!/bin/bash
+
+# Slackware build script for calcure
+
+# Copyright 2023 Tonus Paris
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=calcure
+VERSION=${VERSION:-2.8.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/desktop/calcure/calcure.info b/desktop/calcure/calcure.info
new file mode 100644
index 0000000000..8f5e084b4b
--- /dev/null
+++ b/desktop/calcure/calcure.info
@@ -0,0 +1,10 @@
+PRGNAM="calcure"
+VERSION="2.8.2"
+HOMEPAGE="https://anufrievroman.gitbook.io/calcure"
+DOWNLOAD="https://github.com/anufrievroman/calcure/archive/2.8.2/calcure-2.8.2.tar.gz"
+MD5SUM="d784f06b33ff947c5d0e590aed8ed4ab"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="holidays jdatetime ics"
+MAINTAINER="Tonus"
+EMAIL="tonus1@free.fr"
diff --git a/desktop/calcure/slack-desc b/desktop/calcure/slack-desc
new file mode 100644
index 0000000000..8c41a0e599
--- /dev/null
+++ b/desktop/calcure/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+calcure: calcure (modern TUI calendar and task manager)
+calcure:
+calcure:
+calcure: Calcure is a modern TUI calendar and task manager with customizable
+calcure: interface.
+calcure:
+calcure: The program manages your events and tasks, displays birthdays...
+calcure:
+calcure:
+calcure:
+calcure: