summaryrefslogtreecommitdiffstats
path: root/academic/matplotlib/matplotlib.SlackBuild
diff options
context:
space:
mode:
author Aleksandar Samardzic2010-05-12 17:36:40 +0200
committer Robby Workman2010-05-12 17:36:40 +0200
commit73af4652afaa763e15685757176dae751fe1e3b4 (patch)
treea599ff64d7b407372cfbba83845caed75c78a341 /academic/matplotlib/matplotlib.SlackBuild
parent8bbbece820bf96ecc87d2808de6c2471c0400ec3 (diff)
downloadslackbuilds-73af4652afaa763e15685757176dae751fe1e3b4.tar.gz
academic/matplotlib: Updated for version 0.98.5.2
Diffstat (limited to 'academic/matplotlib/matplotlib.SlackBuild')
-rw-r--r--academic/matplotlib/matplotlib.SlackBuild24
1 files changed, 8 insertions, 16 deletions
diff --git a/academic/matplotlib/matplotlib.SlackBuild b/academic/matplotlib/matplotlib.SlackBuild
index e68e20ef57..de3c3582b2 100644
--- a/academic/matplotlib/matplotlib.SlackBuild
+++ b/academic/matplotlib/matplotlib.SlackBuild
@@ -5,7 +5,7 @@
# Written by Aleksandar Samardzic <asamardzic@gmail.com>
PRGNAM=matplotlib
-VERSION=${VERSION:-0.98.0}
+VERSION=${VERSION:-0.98.5.2}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -15,14 +15,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=${PKG:-$TMP/package-$PRGNAM}
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
-fi
-
set -e
rm -rf $PKG
@@ -38,19 +30,19 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-python setup.py build
python setup.py install --root $PKG
( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-install -m 0644 API_CHANGES CHANGELOG INSTALL INTERACTIVE KNOWN_BUGS \
- README.txt TODO $PKG/usr/doc/$PRGNAM-$VERSION
+install -m 0644 \
+ CHANGELOG INSTALL INTERACTIVE KNOWN_BUGS README.txt TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install