summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Gene Carlson2023-07-04 20:11:07 +0200
committer Matteo Bernardini2024-04-20 17:31:39 +0200
commit340ab7232325fbc99b504f1f3a18a237f34af7f5 (patch)
tree41107eb9eac8496dcc320317d761cb48673265b3
parent7348664936073e3ad54706addd43560c23807ed8 (diff)
downloadslackbuilds-vinterm.tar.gz
system/vinterm: Add missing include for gcc >= 13.x.vinterm
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--system/vinterm/includes.diff10
-rw-r--r--system/vinterm/vinterm.SlackBuild4
2 files changed, 13 insertions, 1 deletions
diff --git a/system/vinterm/includes.diff b/system/vinterm/includes.diff
new file mode 100644
index 0000000000..28b9096c59
--- /dev/null
+++ b/system/vinterm/includes.diff
@@ -0,0 +1,10 @@
+--- vinterm-0.5.0/terminal/pty.h 2013-08-20 01:34:06.000000000 +0900
++++ vinterm-0.5.0.patched/terminal/pty.h 2023-07-01 09:41:53.057899502 +0900
+@@ -3,6 +3,7 @@
+
+ #include <string>
+ #include <ostream>
++#include <cstdint>
+ using namespace std;
+
+ class Options;
diff --git a/system/vinterm/vinterm.SlackBuild b/system/vinterm/vinterm.SlackBuild
index 05afe5718c..5d88b5236d 100644
--- a/system/vinterm/vinterm.SlackBuild
+++ b/system/vinterm/vinterm.SlackBuild
@@ -15,7 +15,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=vinterm
VERSION=${VERSION:-0.5.0}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -66,6 +66,8 @@ sed -i -e "s,-Os,$SLKCFLAGS," -e "s,usr/lib,usr/lib$LIBDIRSUFFIX," config.mk
# GRR. "make install" respects DESTDIR... except for the icons and .desktop.
patch -p1 < $CWD/fix_destdir.diff
+# Add an include statement for GCC compatibility.
+patch -p1 < $CWD/includes.diff
export TERMINFO=$PKG/usr/share/terminfo
mkdir -p $TERMINFO