summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2024-01-27 14:21:30 +0100
committer Matteo Bernardini2024-04-27 10:51:19 +0200
commitc80eff84253f16932eb496e96916c1a44b2aab8f (patch)
tree6dee84eed3482171256407b406e4d88afb742488
parent68ac93024440c1dcb61e579018ce241a1ab44180 (diff)
downloadslackbuilds-python3-webencodings.tar.gz
python/python3-webencodings: Removed (added to Slackware).python3-webencodings
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--python/python3-webencodings/README13
-rw-r--r--python/python3-webencodings/python3-webencodings.SlackBuild99
-rw-r--r--python/python3-webencodings/python3-webencodings.info10
-rw-r--r--python/python3-webencodings/slack-desc19
4 files changed, 0 insertions, 141 deletions
diff --git a/python/python3-webencodings/README b/python/python3-webencodings/README
deleted file mode 100644
index 736e9a2870..0000000000
--- a/python/python3-webencodings/README
+++ /dev/null
@@ -1,13 +0,0 @@
-webencodings is a Python implementation of the WHATWG Encoding standard.
-
-In order to be compatible with legacy web content when interpreting
-something like Content-Type: text/html; charset=latin1, tools need to
-use a particular set of aliases for encoding labels as well as some
-overriding rules. For example, US-ASCII and iso-8859-1 on the web are
-actually aliases for windows-1252, and an UTF-8 or UTF-16 BOM takes
-precedence over any other encoding declaration. The Encoding standard
-defines all such details so that implementations do not have to
-reverse-engineer each other.
-
-This module has encoding labels and BOM detection, but the actual
-implementation for encoders and decoders is Python's.
diff --git a/python/python3-webencodings/python3-webencodings.SlackBuild b/python/python3-webencodings/python3-webencodings.SlackBuild
deleted file mode 100644
index 91b1c7be84..0000000000
--- a/python/python3-webencodings/python3-webencodings.SlackBuild
+++ /dev/null
@@ -1,99 +0,0 @@
-#!/bin/bash
-#
-# SlackBuild for python3-webencodings
-
-# Copyright 2021 Yth | Pont-en-Royans, France | yth@ythogtha.org
-# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python3-webencodings
-SRCNAM=python-webencodings
-VERSION=${VERSION:-0.5.1}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-elif [ "$ARCH" = "aarch64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xzf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-webencodings/python3-webencodings.info b/python/python3-webencodings/python3-webencodings.info
deleted file mode 100644
index cdd96149be..0000000000
--- a/python/python3-webencodings/python3-webencodings.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-webencodings"
-VERSION="0.5.1"
-HOMEPAGE="https://pythonhosted.org/webencodings/"
-DOWNLOAD="https://github.com/gsnedders/python-webencodings/archive/v0.5.1/python-webencodings-0.5.1.tar.gz"
-MD5SUM="7eb67377743cd55eaa356496c439471e"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Yth - Arnaud"
-EMAIL="yth@ythogtha.org"
diff --git a/python/python3-webencodings/slack-desc b/python/python3-webencodings/slack-desc
deleted file mode 100644
index 2b41d21154..0000000000
--- a/python/python3-webencodings/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-webencodings: python3-webencodings (Character encoding for the web)
-python3-webencodings:
-python3-webencodings: webencodings is a Python implementation of the WHATWG Encoding
-python3-webencodings: standard.
-python3-webencodings:
-python3-webencodings:
-python3-webencodings:
-python3-webencodings:
-python3-webencodings:
-python3-webencodings:
-python3-webencodings: