summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2023-11-25 21:13:39 +0100
committer Matteo Bernardini2024-04-20 17:30:09 +0200
commit1e11f6ab58de8f728fd42776fa3d54f312c6f1ec (patch)
tree07a131b85efca7d241a8b2a6ec8f39f33a5369e2
parent7348664936073e3ad54706addd43560c23807ed8 (diff)
downloadslackbuilds-python3-typogrify.tar.gz
python/python3-typogrify: Removed (added to Slackware).python3-typogrify
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--python/python3-typogrify/README5
-rw-r--r--python/python3-typogrify/python3-typogrify.SlackBuild95
-rw-r--r--python/python3-typogrify/python3-typogrify.info10
-rw-r--r--python/python3-typogrify/slack-desc19
4 files changed, 0 insertions, 129 deletions
diff --git a/python/python3-typogrify/README b/python/python3-typogrify/README
deleted file mode 100644
index 7b85ea97e3..0000000000
--- a/python/python3-typogrify/README
+++ /dev/null
@@ -1,5 +0,0 @@
-Typogrify provides a set of custom filters that automatically apply
-various transformations to plain text in order to yield
-typographically-improved HTML. While often used in conjunction with
-Jinja and Django template systems, the filters can be used in any
-environment.
diff --git a/python/python3-typogrify/python3-typogrify.SlackBuild b/python/python3-typogrify/python3-typogrify.SlackBuild
deleted file mode 100644
index e504fd7071..0000000000
--- a/python/python3-typogrify/python3-typogrify.SlackBuild
+++ /dev/null
@@ -1,95 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python3-typogrify
-
-# Copyright 2022 Steven Voges <Oregon, USA>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python3-typogrify
-SRCNAM=typogrify
-VERSION=${VERSION:-2.0.7}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- LICENSE.txt PKG-INFO README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-typogrify/python3-typogrify.info b/python/python3-typogrify/python3-typogrify.info
deleted file mode 100644
index 8d9d21e089..0000000000
--- a/python/python3-typogrify/python3-typogrify.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-typogrify"
-VERSION="2.0.7"
-HOMEPAGE="https://github.com/mintchaos/typogrify"
-DOWNLOAD="https://files.pythonhosted.org/packages/8a/bf/64959d6187d42472acb846bcf462347c9124952c05bd57e5769d5f28f9a6/typogrify-2.0.7.tar.gz"
-MD5SUM="63f38f80531996f187d2894cc497ba08"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python-smartypants"
-MAINTAINER="Steven Voges"
-EMAIL="svoges.sbo@gmail.com"
diff --git a/python/python3-typogrify/slack-desc b/python/python3-typogrify/slack-desc
deleted file mode 100644
index f8a55e6af9..0000000000
--- a/python/python3-typogrify/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-typogrify: python3-typogrify (Text to HTML translator)
-python3-typogrify:
-python3-typogrify: A set of Django template filters to make caring about typography on
-python3-typogrify: the web a bit easier.
-python3-typogrify:
-python3-typogrify: Homepage: https://github.com/mintchaos/typogrify
-python3-typogrify:
-python3-typogrify:
-python3-typogrify:
-python3-typogrify:
-python3-typogrify: