summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2023-12-02 08:57:08 +0100
committer Matteo Bernardini2024-04-20 17:29:55 +0200
commit63015f7186dbf05ac8a78e7c7022a58f56cad175 (patch)
tree1bb31369abc19d8749977b110a00fb207b25996f
parent7348664936073e3ad54706addd43560c23807ed8 (diff)
downloadslackbuilds-python3-pyproject-hooks.tar.gz
python/python3-pyproject-hooks: Removed (added to Slackware).python3-pyproject-hooks
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--python/python3-pyproject-hooks/README9
-rw-r--r--python/python3-pyproject-hooks/python3-pyproject-hooks.SlackBuild98
-rw-r--r--python/python3-pyproject-hooks/python3-pyproject-hooks.info10
-rw-r--r--python/python3-pyproject-hooks/slack-desc19
4 files changed, 0 insertions, 136 deletions
diff --git a/python/python3-pyproject-hooks/README b/python/python3-pyproject-hooks/README
deleted file mode 100644
index dfa06b5179..0000000000
--- a/python/python3-pyproject-hooks/README
+++ /dev/null
@@ -1,9 +0,0 @@
-python3-pyproject-hooks (Wrappers to call PEP 517 build backend hooks)
-
-This is a low-level library for calling build-backends in
-pyproject.toml-based project. It provides the basic functionality to
-help write tooling that generates distribution files from
-Python projects.
-
-The pep517 project has been replaced by this project (low level) and
-the build project (high level).
diff --git a/python/python3-pyproject-hooks/python3-pyproject-hooks.SlackBuild b/python/python3-pyproject-hooks/python3-pyproject-hooks.SlackBuild
deleted file mode 100644
index acffa128e7..0000000000
--- a/python/python3-pyproject-hooks/python3-pyproject-hooks.SlackBuild
+++ /dev/null
@@ -1,98 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python3-pyproject-hooks
-
-# Copyright 2023 fourtysixandtwo <fourtysixandtwo@sliderr.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python3-pyproject-hooks
-SRCNAM=$(echo ${PRGNAM#python3-*} | sed -e "s/-/_/")
-VERSION=${VERSION:-1.0.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 -m flit_core.wheel
-python3 -m installer -d "$PKG" dist/*.whl
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- PKG-INFO \
- README.rst \
- LICENSE \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-pyproject-hooks/python3-pyproject-hooks.info b/python/python3-pyproject-hooks/python3-pyproject-hooks.info
deleted file mode 100644
index 59e5d918ae..0000000000
--- a/python/python3-pyproject-hooks/python3-pyproject-hooks.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-pyproject-hooks"
-VERSION="1.0.0"
-HOMEPAGE="https://github.com/pypa/pyproject-hooks"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/p/pyproject_hooks/pyproject_hooks-1.0.0.tar.gz"
-MD5SUM="69b0b6de189bc04c3f9e304281765741"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3-installer"
-MAINTAINER="fourtysixandtwo"
-EMAIL="fourtysixandtwo@sliderr.net"
diff --git a/python/python3-pyproject-hooks/slack-desc b/python/python3-pyproject-hooks/slack-desc
deleted file mode 100644
index 57fe2f9534..0000000000
--- a/python/python3-pyproject-hooks/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-pyproject-hooks: python3-pyproject-hooks (Wrappers to call PEP 517 build backend hooks)
-python3-pyproject-hooks:
-python3-pyproject-hooks: This is a low-level library for calling build-backends in
-python3-pyproject-hooks: pyproject.toml-based project. It provides the basic functionality to
-python3-pyproject-hooks: help write tooling that generates distribution files from
-python3-pyproject-hooks: Python projects.
-python3-pyproject-hooks:
-python3-pyproject-hooks: The pep517 project has been replaced by this project (low level) and
-python3-pyproject-hooks: the build project (high level).
-python3-pyproject-hooks:
-python3-pyproject-hooks: Homepage: https://github.com/pypa/pyproject-hooks