summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2024-03-30 09:03:40 +0100
committer Matteo Bernardini2024-04-20 17:29:24 +0200
commit74ae81f4493c3b379f43bb7ba5d9ca6c83295f94 (patch)
tree3f7b001817ad4f7470f3180545a0534793fa8e33
parent7348664936073e3ad54706addd43560c23807ed8 (diff)
downloadslackbuilds-python3-build.tar.gz
python/python3-build: Removed (added to Slackware).python3-build
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--python/python3-build/README9
-rw-r--r--python/python3-build/python3-build.SlackBuild89
-rw-r--r--python/python3-build/python3-build.info10
-rw-r--r--python/python3-build/slack-desc19
4 files changed, 0 insertions, 127 deletions
diff --git a/python/python3-build/README b/python/python3-build/README
deleted file mode 100644
index 204337b288..0000000000
--- a/python/python3-build/README
+++ /dev/null
@@ -1,9 +0,0 @@
-A simple, correct PEP517 package builder.
-
-NOTE:
- Has a soft requirement for python-importlib_metadata (and python-zipp)
- which should be installed as it fixes a stdlib bug, but newer versions
- have a circular dep on this slackbuild so cannot be built before it.
- Therefore it will NOT be added to REQUIRES here.
-
- This change will not affect most python builds.
diff --git a/python/python3-build/python3-build.SlackBuild b/python/python3-build/python3-build.SlackBuild
deleted file mode 100644
index bed9b2dd61..0000000000
--- a/python/python3-build/python3-build.SlackBuild
+++ /dev/null
@@ -1,89 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python3-build
-
-# Copyright 2023-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
-# Copyright 2022 toolonely <lonely_@tutanota.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# 20230507 46and2: New maintainer, updated version and deps.
-# -build process changed
-# 20231212 46and2: Remove python-importlib_metadata as dep, see README.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python3-build
-SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-1.2.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \+ -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-
-python3 -m flit_core.wheel
-python3 -m installer -d "$PKG" dist/*.whl
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- PKG-INFO \
- README.md \
- LICENSE \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-build/python3-build.info b/python/python3-build/python3-build.info
deleted file mode 100644
index ad5c5be3b2..0000000000
--- a/python/python3-build/python3-build.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-build"
-VERSION="1.2.1"
-HOMEPAGE="https://github.com/pypa/build"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/b/build/build-1.2.1.tar.gz"
-MD5SUM="9675d7b278f4533b9b75701e6e87390b"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3-pyproject-hooks"
-MAINTAINER="fourtysixandtwo"
-EMAIL="fourtysixandtwo@sliderr.net"
diff --git a/python/python3-build/slack-desc b/python/python3-build/slack-desc
deleted file mode 100644
index e81b98eb3b..0000000000
--- a/python/python3-build/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-build: python3-build (a simple, correct PEP517 package builder)
-python3-build:
-python3-build: Homepage: https://github.com/pypa/build
-python3-build:
-python3-build:
-python3-build:
-python3-build:
-python3-build:
-python3-build:
-python3-build:
-python3-build: