summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2023-11-25 21:12:06 +0100
committer Matteo Bernardini2024-04-20 17:29:12 +0200
commite82456601cabb5c48b7214ba8ab3eae52676bbb3 (patch)
treebab4dc826ad694d2a02e8464e5ea43a53e70dc8e
parent7348664936073e3ad54706addd43560c23807ed8 (diff)
downloadslackbuilds-python-smartypants.tar.gz
python/python-smartypants: Removed (added to Slackware).python-smartypants
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--python/python-smartypants/README4
-rw-r--r--python/python-smartypants/python-smartypants.SlackBuild96
-rw-r--r--python/python-smartypants/python-smartypants.info10
-rw-r--r--python/python-smartypants/slack-desc19
4 files changed, 0 insertions, 129 deletions
diff --git a/python/python-smartypants/README b/python/python-smartypants/README
deleted file mode 100644
index f91f30930a..0000000000
--- a/python/python-smartypants/README
+++ /dev/null
@@ -1,4 +0,0 @@
-smartypants.py is a Python fork of SmartyPants.
-
-Translate plain ASCII punctuation characters into "smart" typographic
-punctuation HTML entities.
diff --git a/python/python-smartypants/python-smartypants.SlackBuild b/python/python-smartypants/python-smartypants.SlackBuild
deleted file mode 100644
index b52fc9fa0e..0000000000
--- a/python/python-smartypants/python-smartypants.SlackBuild
+++ /dev/null
@@ -1,96 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python-smartypants
-
-# Copyright 2022 Steven Voges <Oregon, USA>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python-smartypants
-SRCNAM=smartypants.py
-VERSION=${VERSION:-2.0.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- *.rst COPYING docs/*.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python-smartypants/python-smartypants.info b/python/python-smartypants/python-smartypants.info
deleted file mode 100644
index 6d5ce4d88c..0000000000
--- a/python/python-smartypants/python-smartypants.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-smartypants"
-VERSION="2.0.1"
-HOMEPAGE="https://github.com/leohemsted/smartypants.py"
-DOWNLOAD="https://github.com/leohemsted/smartypants.py/archive/v2.0.1/smartypants.py-2.0.1.tar.gz"
-MD5SUM="27957540f4718e892039b2ed208c78f3"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Steven Voges"
-EMAIL="svoges.sbo@gmail.com"
diff --git a/python/python-smartypants/slack-desc b/python/python-smartypants/slack-desc
deleted file mode 100644
index ac1deaef3a..0000000000
--- a/python/python-smartypants/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-smartypants: python-smartypants (Smart Punctuation for Web Sites)
-python-smartypants:
-python-smartypants: Translate plain ASCII punctuation characters into "smart" typographic
-python-smartypants: punctuation HTML entities.
-python-smartypants:
-python-smartypants: Homepage: https://github.com/leohemsted/smartypants.py
-python-smartypants:
-python-smartypants:
-python-smartypants:
-python-smartypants:
-python-smartypants: