summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2024-04-05 22:41:04 +0200
committer Matteo Bernardini2024-04-20 17:27:31 +0200
commit3b655474199459110392beadfb0a330837ed52b8 (patch)
treec1decba132356211cca5271dc89159d26c0572f0
parent7348664936073e3ad54706addd43560c23807ed8 (diff)
downloadslackbuilds-libplacebo.tar.gz
graphics/libplacebo: Removed (added to Slackware).libplacebo
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--graphics/libplacebo/README3
-rw-r--r--graphics/libplacebo/libplacebo.SlackBuild115
-rw-r--r--graphics/libplacebo/libplacebo.info10
-rw-r--r--graphics/libplacebo/slack-desc19
-rw-r--r--graphics/libplacebo/use_meson-0.59.4.diff11
5 files changed, 0 insertions, 158 deletions
diff --git a/graphics/libplacebo/README b/graphics/libplacebo/README
deleted file mode 100644
index eff104786c..0000000000
--- a/graphics/libplacebo/README
+++ /dev/null
@@ -1,3 +0,0 @@
-libplacebo is essentially the core rendering algorithms and ideas of mpv
-turned into a library.
-
diff --git a/graphics/libplacebo/libplacebo.SlackBuild b/graphics/libplacebo/libplacebo.SlackBuild
deleted file mode 100644
index ddda6f8e38..0000000000
--- a/graphics/libplacebo/libplacebo.SlackBuild
+++ /dev/null
@@ -1,115 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for libplacebo
-
-# Copyright 2019-2020 Hunter Sezen California, USA
-# Copyright 2023 Christoph Willing Brisbane, Australia
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=libplacebo
-VERSION=${VERSION:-6.338.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -eu
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-v$VERSION
-tar xvf $CWD/$PRGNAM-v$VERSION.tar.gz
-cd $PRGNAM-v$VERSION
-patch -p0 < $CWD/use_meson-0.59.4.diff
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-if [ "${DEBUG:=0}" != 0 ]; then
- NDEBUG=false
- RELEASE=debug
- SLKCFLAGS="$(printf %s "$SLKCFLAGS" | sed 's/-O2/-O0/')"
-else
- NDEBUG=true
- RELEASE=plain
-fi
-
-PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
-export PYTHONPATH=/opt/python$PYVER/site-packages/
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-meson \
- --prefix=/usr \
- --libdir=lib${LIBDIRSUFFIX} \
- -Dstrip=$NDEBUG \
- -Db_ndebug=$NDEBUG \
- -Dbuildtype=$RELEASE \
- -Ddemos=false \
- build
-
-"${NINJA:=ninja}" -C build
-DESTDIR=$PKG "$NINJA" -C build install
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/graphics/libplacebo/libplacebo.info b/graphics/libplacebo/libplacebo.info
deleted file mode 100644
index 0bbbb982d8..0000000000
--- a/graphics/libplacebo/libplacebo.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="libplacebo"
-VERSION="6.338.1"
-HOMEPAGE="https://code.videolan.org/videolan/libplacebo"
-DOWNLOAD="https://code.videolan.org/videolan/libplacebo/-/archive/v6.338.1/libplacebo-v6.338.1.tar.gz"
-MD5SUM="36f5d178cc8a5366e35fe1e7400c19c3"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3-meson-opt python3-glad"
-MAINTAINER="Christoph Willing"
-EMAIL="chris.willing@linux.com"
diff --git a/graphics/libplacebo/slack-desc b/graphics/libplacebo/slack-desc
deleted file mode 100644
index cdb54a9292..0000000000
--- a/graphics/libplacebo/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-libplacebo: libplacebo (GPU-accelerated video/image rendering primitives library)
-libplacebo:
-libplacebo: libplacebo is essentially the core rendering algorithms and ideas of
-libplacebo: mpv turned into a library.
-libplacebo:
-libplacebo: Homepage: https://code.videolan.org/videolan/libplacebo
-libplacebo:
-libplacebo:
-libplacebo:
-libplacebo:
-libplacebo:
diff --git a/graphics/libplacebo/use_meson-0.59.4.diff b/graphics/libplacebo/use_meson-0.59.4.diff
deleted file mode 100644
index 3c1c83ebde..0000000000
--- a/graphics/libplacebo/use_meson-0.59.4.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- meson.build.orig 2023-03-24 00:53:00.000000000 +1000
-+++ meson.build 2023-08-23 10:52:45.189000000 +1000
-@@ -6,7 +6,7 @@
- 'c_std=c11',
- 'cpp_std=c++11',
- ],
-- meson_version: '>=0.63',
-+ meson_version: '>=0.59.4',
- version: '@0@.@1@.@2@'.format(
- # Major version
- 5,