summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2024-04-06 23:07:27 +0200
committer Matteo Bernardini2024-04-27 10:37:15 +0200
commitd0f2aa7c4c2c0e97d96e11dfadcc943dc47c179d (patch)
treecec713128cf3c0d54e9e6d0e04e9102081ec55ab
parent68ac93024440c1dcb61e579018ce241a1ab44180 (diff)
downloadslackbuilds-jupyter-nbclassic.tar.gz
development/jupyter-nbclassic: Updated for the new python.jupyter-nbclassic
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--development/jupyter-nbclassic/jupyter-nbclassic.SlackBuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/development/jupyter-nbclassic/jupyter-nbclassic.SlackBuild b/development/jupyter-nbclassic/jupyter-nbclassic.SlackBuild
index 104abca582..8e69e7f4bf 100644
--- a/development/jupyter-nbclassic/jupyter-nbclassic.SlackBuild
+++ b/development/jupyter-nbclassic/jupyter-nbclassic.SlackBuild
@@ -78,16 +78,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fix /etc/jupyter path
-sed 's|etc|/etc|' -i setup.cfg
-
-python3 setup.py install --root=$PKG
+python -m build --wheel --no-isolation --skip-dependency-check
+python -m installer --destdir=$PKG dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
# Remove bundled mathjax2; replace with system mathjax2
-PYTHONPATH=$(python3 -c "from sysconfig import get_path; print(get_path('platlib'))")
+PYTHONPATH=$(python3 -c "from sysconfig import get_path; print(get_path('purelib'))")
rm -r $PKG/$PYTHONPATH/nbclassic/static/components/MathJax
ln -sr /usr/share/mathjax2 $PKG/$PYTHONPATH/nbclassic/static/components/MathJax