summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Howard Pepper2011-08-22 02:49:11 +0200
committer Niels Horn2011-08-22 02:49:11 +0200
commit10e6a88e06d66c664f66b8973602462e90c16993 (patch)
tree4c0b62e6843de5f9b273cc9bda2d72288bc8e68e
parent70b7572e8b8fb6185739ce2608b078636599b723 (diff)
downloadslackbuilds-10e6a88e06d66c664f66b8973602462e90c16993.tar.gz
office/pdfshuffler: Added (python pdf manipulator)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
-rw-r--r--office/pdfshuffler/README6
-rw-r--r--office/pdfshuffler/doinst.sh3
-rw-r--r--office/pdfshuffler/pdfshuffler.SlackBuild80
-rw-r--r--office/pdfshuffler/pdfshuffler.info10
-rw-r--r--office/pdfshuffler/slack-desc19
5 files changed, 118 insertions, 0 deletions
diff --git a/office/pdfshuffler/README b/office/pdfshuffler/README
new file mode 100644
index 0000000000..fafa48d633
--- /dev/null
+++ b/office/pdfshuffler/README
@@ -0,0 +1,6 @@
+PDF-Shuffler is a small python-gtk application, which helps the user to
+merge or split pdf documents and rotate, crop and rearrange their pages
+using an interactive and intuitive graphical interface. It is a frontend
+for python-pyPdf.
+
+This requires pypoppler and pyPdf.
diff --git a/office/pdfshuffler/doinst.sh b/office/pdfshuffler/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/office/pdfshuffler/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/office/pdfshuffler/pdfshuffler.SlackBuild b/office/pdfshuffler/pdfshuffler.SlackBuild
new file mode 100644
index 0000000000..c662236eee
--- /dev/null
+++ b/office/pdfshuffler/pdfshuffler.SlackBuild
@@ -0,0 +1,80 @@
+#!/bin/sh
+
+# Slackware build script for pdfshuffler.
+#
+# Copyright 2011 Howard Pepper <h_pepper <at> bellsouth {dot} net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pdfshuffler
+VERSION=0.5.1
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="README"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mv $PKG/usr/share/man $PKG/usr
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/office/pdfshuffler/pdfshuffler.info b/office/pdfshuffler/pdfshuffler.info
new file mode 100644
index 0000000000..5595345918
--- /dev/null
+++ b/office/pdfshuffler/pdfshuffler.info
@@ -0,0 +1,10 @@
+PRGNAM="pdfshuffler"
+VERSION="0.5.1"
+HOMEPAGE="http://pdfshuffler.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/pdfshuffler/pdfshuffler-0.5.1.tar.gz"
+MD5SUM="a63e4e37c822e6bd3932aed53ad3e070"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Howard Pepper"
+EMAIL="h_pepper <at> bellsouth {dot} net"
+APPROVED="Niels Horn"
diff --git a/office/pdfshuffler/slack-desc b/office/pdfshuffler/slack-desc
new file mode 100644
index 0000000000..5012284b10
--- /dev/null
+++ b/office/pdfshuffler/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+pdfshuffler: pdfshuffler (python pdf manipulator)
+pdfshuffler:
+pdfshuffler: PDF-Shuffler is a small python-gtk application, which helps
+pdfshuffler: the user to merge or split pdf documents and rotate, crop and
+pdfshuffler: rearrange their pages using an interactive and intuitive
+pdfshuffler: graphical interface. It is a frontend for python-pyPdf.
+pdfshuffler:
+pdfshuffler:
+pdfshuffler:
+pdfshuffler:
+pdfshuffler: