summaryrefslogtreecommitdiffstats
path: root/python/Mako
diff options
context:
space:
mode:
Diffstat (limited to 'python/Mako')
-rw-r--r--python/Mako/Mako.SlackBuild69
-rw-r--r--python/Mako/Mako.info10
-rw-r--r--python/Mako/README9
-rw-r--r--python/Mako/slack-desc19
4 files changed, 0 insertions, 107 deletions
diff --git a/python/Mako/Mako.SlackBuild b/python/Mako/Mako.SlackBuild
deleted file mode 100644
index 814d6ef087..0000000000
--- a/python/Mako/Mako.SlackBuild
+++ /dev/null
@@ -1,69 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for Mako
-
-# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
-# Copyright 2017 Hunter Sezen California, USA
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=Mako
-VERSION=${VERSION:-1.0.7}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -eu
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS CHANGES LICENSE README.rst doc/*.html \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/Mako/Mako.info b/python/Mako/Mako.info
deleted file mode 100644
index b55b94d692..0000000000
--- a/python/Mako/Mako.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="Mako"
-VERSION="1.0.7"
-HOMEPAGE="http://www.makotemplates.org/"
-DOWNLOAD="https://pypi.python.org/packages/eb/f3/67579bb486517c0d49547f9697e36582cd19dafb5df9e687ed8e22de57fa/Mako-1.0.7.tar.gz"
-MD5SUM="5836cc997b1b773ef389bf6629c30e65"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="MarkupSafe"
-MAINTAINER="Hunter Sezen"
-EMAIL="orbea@fredslev.dk"
diff --git a/python/Mako/README b/python/Mako/README
deleted file mode 100644
index 9fa6aa27e2..0000000000
--- a/python/Mako/README
+++ /dev/null
@@ -1,9 +0,0 @@
-Mako is a template library written in Python. It provides a familiar,
-non-XML syntax which compiles into Python modules for maximum
-performance. Mako's syntax and API borrows from the best ideas of many
-others, including Django templates, Cheetah, Myghty, and Genshi.
-Conceptually, Mako is an embedded Python (i.e. Python Server Page)
-language, which refines the familiar ideas of componentized layout and
-inheritance to produce one of the most straightforward and flexible
-models available, while also maintaining close ties to Python calling
-and scoping semantics.
diff --git a/python/Mako/slack-desc b/python/Mako/slack-desc
deleted file mode 100644
index 3ae4979cac..0000000000
--- a/python/Mako/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-Mako: Mako (A python templating language)
-Mako:
-Mako: Mako is a template library written in Python. It provides a familiar,
-Mako: non-XML syntax which compiles into Python modules for maximum
-Mako: performance. Mako's syntax and API borrows from the best ideas of many
-Mako: others, including Django templates, Cheetah, Myghty, and Genshi.
-Mako: Conceptually, Mako is an embedded Python (i.e. Python Server Page)
-Mako: language, which refines the familiar ideas of componentized layout and
-Mako: inheritance to produce one of the most straightforward and flexible
-Mako: models available, while also maintaining close ties to Python.
-Mako: Homepage: http://www.makotemplates.org/