summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
Diffstat (limited to 'office')
-rw-r--r--office/apvlv/apvlv.SlackBuild25
-rw-r--r--office/apvlv/apvlv.info6
-rw-r--r--office/coolreader/coolreader.SlackBuild45
-rw-r--r--office/coolreader/coolreader.info8
-rw-r--r--office/fbreader/fbreader.SlackBuild3
-rw-r--r--office/gbgoffice/gbgoffice.SlackBuild1
-rw-r--r--office/gbgoffice/patches/12_gcc6.patch21
-rw-r--r--office/gnokii/gnokii-0.6.31-gcc7.patch17
-rw-r--r--office/gnokii/gnokii.SlackBuild3
-rw-r--r--office/htmldoc/build_fix.patch13
-rw-r--r--office/htmldoc/htmldoc.SlackBuild20
-rw-r--r--office/htmldoc/htmldoc.info8
-rw-r--r--office/htmldoc/slack-desc2
-rw-r--r--office/juffed/README6
-rw-r--r--office/juffed/doinst.sh3
-rw-r--r--office/juffed/juffed.SlackBuild99
-rw-r--r--office/juffed/juffed.info10
-rw-r--r--office/juffed/slack-desc19
-rw-r--r--office/kbgoffice/gcc6.patch17
-rw-r--r--office/kbgoffice/kbgoffice.SlackBuild3
-rw-r--r--office/referencer/referencer-lib_path.patch11
-rw-r--r--office/referencer/referencer.SlackBuild3
22 files changed, 148 insertions, 195 deletions
diff --git a/office/apvlv/apvlv.SlackBuild b/office/apvlv/apvlv.SlackBuild
index 5246eb400f..62eff77de8 100644
--- a/office/apvlv/apvlv.SlackBuild
+++ b/office/apvlv/apvlv.SlackBuild
@@ -23,15 +23,14 @@
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
# THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
PRGNAM=apvlv
-VERSION=${VERSION:-0.1.4}
+VERSION=${VERSION:-20160627_9ab7626}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -42,8 +41,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -61,21 +60,21 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION-Source
-tar xvf $CWD/$PRGNAM-$VERSION-Source.tar.gz
-cd $PRGNAM-$VERSION-Source
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
mkdir -p build
cd build
cmake .. \
-DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_CXX_FLAGS_RELEASE="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS_RELEASE="$SLKCFLAGS -fpermissive" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DAPVLV_WITH_UMD=false \
-DMANDIR=/usr/man \
diff --git a/office/apvlv/apvlv.info b/office/apvlv/apvlv.info
index da882def19..4df540a600 100644
--- a/office/apvlv/apvlv.info
+++ b/office/apvlv/apvlv.info
@@ -1,8 +1,8 @@
PRGNAM="apvlv"
-VERSION="0.1.4"
+VERSION="20160627_9ab7626"
HOMEPAGE="http://naihe2010.github.com/apvlv/"
-DOWNLOAD="https://github.com/downloads/naihe2010/apvlv/apvlv-0.1.4-Source.tar.gz"
-MD5SUM="bcd3e96350a2378662e2f2d0fa02d342"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/apvlv-20160627_9ab7626.tar.xz"
+MD5SUM="e7a285ca7ac4d3abc1842519c0f20987"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/office/coolreader/coolreader.SlackBuild b/office/coolreader/coolreader.SlackBuild
index d4cd5b4820..dd38f2cb84 100644
--- a/office/coolreader/coolreader.SlackBuild
+++ b/office/coolreader/coolreader.SlackBuild
@@ -22,19 +22,16 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# Upsteam url: https://sourceforge.net/p/crengine/crengine/ci/master/tree/
+
PRGNAM=coolreader
-VERSION=${VERSION:-3.0.56}
+VERSION=${VERSION:-20160825_d8a3a1b}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-ORIG_PRGNAM=cr3
-ORIG_VERSION=$VERSION-7
-ORIG_DIRNAME=cr$ORIG_VERSION
-ORIG_FILENAME=${ORIG_PRGNAM}_$VERSION.orig.tar.gz
-
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -45,8 +42,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -59,28 +56,34 @@ else
LIBDIRSUFFIX=""
fi
+ORIG_PRGNAM=cr3
+
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $ORIG_DIRNAME
-tar xvf $CWD/$ORIG_FILENAME
-cd $ORIG_DIRNAME
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
+cd $PRGNAM-$VERSION
chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
mkdir -p build
cd build
cmake \
- -D CMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -D CMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -D CMAKE_INSTALL_PREFIX=/usr \
- -D LIB_SUFFIX=${LIBDIRSUFFIX} \
- -D CMAKE_BUILD_TYPE=Release \
- -D MAX_IMAGE_SCALE_MUL=2 \
- -D DOC_DATA_COMPRESSION_LEVEL=3 \
- -D DOC_BUFFER_SIZE=0x1400000 \
- -D GUI=QT ..
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DMAX_IMAGE_SCALE_MUL=2 \
+ -DDOC_DATA_COMPRESSION_LEVEL=3 \
+ -DDOC_BUFFER_SIZE=0x1400000 \
+ -DGUI=QT ..
make VERBOSE=1
make install DESTDIR=$PKG
cd ..
diff --git a/office/coolreader/coolreader.info b/office/coolreader/coolreader.info
index 108d2cced0..8e673e0614 100644
--- a/office/coolreader/coolreader.info
+++ b/office/coolreader/coolreader.info
@@ -1,8 +1,8 @@
PRGNAM="coolreader"
-VERSION="3.0.56"
-HOMEPAGE="http://coolreader.org"
-DOWNLOAD="http://downloads.sourceforge.net/crengine/CoolReader3/cr3_3.0.56.orig.tar.gz"
-MD5SUM="cc221a608a1b5fea2db5a519c14eeb39"
+VERSION="20160825_d8a3a1b"
+HOMEPAGE="https://crengine.sourceforge.io"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/coolreader-20160825_d8a3a1b.tar.xz"
+MD5SUM="0c65e080d2cba8213dd19fb26f4ad9b3"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/office/fbreader/fbreader.SlackBuild b/office/fbreader/fbreader.SlackBuild
index d5c54adeac..d19b2904a3 100644
--- a/office/fbreader/fbreader.SlackBuild
+++ b/office/fbreader/fbreader.SlackBuild
@@ -56,6 +56,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Needed for gcc >= 6.x
+sed -i "s|-Wall|-Wall -Wno-narrowing|" makefiles/arch/desktop.mk
+
patch -p1 < $CWD/fbreader-0.99.4.patch
export TARGET_ARCH=desktop
diff --git a/office/gbgoffice/gbgoffice.SlackBuild b/office/gbgoffice/gbgoffice.SlackBuild
index 08a3eac59b..268a1f6f00 100644
--- a/office/gbgoffice/gbgoffice.SlackBuild
+++ b/office/gbgoffice/gbgoffice.SlackBuild
@@ -78,6 +78,7 @@ patch -p1 -i $CWD/patches/08_fix_const_conversion.patch
patch -p1 -i $CWD/patches/09_deprecated_SigC.patch
patch -p1 -i $CWD/patches/10_workhelper-buttonbox.patch
patch -p1 -i $CWD/patches/11_explicit-linkage.patch
+patch -p1 -i $CWD/patches/12_gcc6.patch
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS -std=c++11" \
diff --git a/office/gbgoffice/patches/12_gcc6.patch b/office/gbgoffice/patches/12_gcc6.patch
new file mode 100644
index 0000000000..2ec2c344f4
--- /dev/null
+++ b/office/gbgoffice/patches/12_gcc6.patch
@@ -0,0 +1,21 @@
+Description: fixes compilation with GCC-6
+ return type must be Translator* and can't be boolean
+Author: Damyan Ivanov <dmn@debian.org>
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=811619
+
+--- a/src/translator_manager.cpp
++++ b/src/translator_manager.cpp
+@@ -176,11 +176,11 @@ Translator *TranslatorManager::getTestDi
+ isDataOk = isDataOk && tr->init(tr->BG_EN, string(string(prop->getDirectory()) + prop->getString("data")).c_str());
+ } else {
+ cerr << "TranslatorManager::getTestDictionaryObject - Wrong description file: " << testDictionaries[index].fileName << "\n";
+- return false;
++ return NULL;
+ }
+ if (!isDataOk) {
+ cerr << "TranslatorManager::getTestDictionaryObject - Problem initialazing dictionary: " << testDictionaries[index].fileName << "\n";
+- return false;
++ return NULL;
+ }
+ char c[16];
+ sprintf(c, "%d", level);
diff --git a/office/gnokii/gnokii-0.6.31-gcc7.patch b/office/gnokii/gnokii-0.6.31-gcc7.patch
new file mode 100644
index 0000000000..6637a6af62
--- /dev/null
+++ b/office/gnokii/gnokii-0.6.31-gcc7.patch
@@ -0,0 +1,17 @@
+Patch by Robert Scheck <robert@fedoraproject.org> for gnokii <= 0.6.31 to avoid
+build failures with GCC 7.x as "../common/.libs/libgnokii.so: undefined reference
+to `local_atoi'". The "inline" is only a hint that the compiler doesn't complain
+about double defined symbols, but does not guarantee that a function is inlined
+or that a symbol is generated when needed.
+
+--- gnokii-0.6.31/common/gsm-filetypes.c 2011-12-02 15:53:04.000000000 +0100
++++ gnokii-0.6.31/common/gsm-filetypes.c.gcc7 2017-02-12 00:55:39.000000000 +0100
+@@ -1409,7 +1409,7 @@
+ #define GET_NEXT_TOKEN() o = get_next_token(line + offset, ';')
+ #define STORE_TOKEN(a) strip_slashes(a, line + offset, sizeof(a) - 1, o - 1)
+
+-inline int local_atoi(char *str, int len)
++static int local_atoi(char *str, int len)
+ {
+ int retval;
+ char *aux = strndup(str, len);
diff --git a/office/gnokii/gnokii.SlackBuild b/office/gnokii/gnokii.SlackBuild
index eb3b4f1519..5301e1c7cf 100644
--- a/office/gnokii/gnokii.SlackBuild
+++ b/office/gnokii/gnokii.SlackBuild
@@ -73,6 +73,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Thnx to fedora for this patch
+patch -p1 < $CWD/gnokii-0.6.31-gcc7.patch
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
diff --git a/office/htmldoc/build_fix.patch b/office/htmldoc/build_fix.patch
new file mode 100644
index 0000000000..280ee4e554
--- /dev/null
+++ b/office/htmldoc/build_fix.patch
@@ -0,0 +1,13 @@
+diff --git a/htmldoc/htmlsep.cxx b/htmldoc/htmlsep.cxx
+index f2d57bff..d9b2ca30 100644
+--- a/htmldoc/htmlsep.cxx
++++ b/htmldoc/htmlsep.cxx
+@@ -517,7 +517,7 @@ write_doc(FILE **out, // I - Output file
+ if (t->markup >= MARKUP_H1 && t->markup < (MARKUP_H1 + TocLevels) &&
+ htmlGetVariable(t, (uchar *)"_HD_OMIT_TOC") == NULL)
+ {
+- if (heading >= 0)
++ if (*heading >= 0)
+ write_footer(out, *heading);
+
+ (*heading) ++;
diff --git a/office/htmldoc/htmldoc.SlackBuild b/office/htmldoc/htmldoc.SlackBuild
index f88d47c057..82de064e9f 100644
--- a/office/htmldoc/htmldoc.SlackBuild
+++ b/office/htmldoc/htmldoc.SlackBuild
@@ -31,7 +31,7 @@
# not being copied into the package
PRGNAM=htmldoc
-VERSION=${VERSION:-1.8.29}
+VERSION=${VERSION:-1.8.30}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -48,7 +48,7 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCFILES="CHANGES.txt README.txt COMPILE.txt COPYING.txt htmldoc.readme"
+DOCFILES="CHANGES.md README.md COPYING"
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
@@ -70,7 +70,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION-source.tar.bz2
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -79,6 +79,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Upstream compiler fix
+patch -p1 < $CWD/build_fix.patch
+
# workaround to avoid /usr/share/doc/htmldoc's use for help function
sed -r -i 's|^#define DOCUMENTATION "$prefix/share/doc/htmldoc"|\
#define DOCUMENTATION "$prefix/doc/htmldoc-$VERSION"|g' ./configure
@@ -117,23 +120,16 @@ mkdir -p $PKG/usr/man/man1
cp -a doc/$PRGNAM.1 $PKG/usr/man/man1
mkdir -p $PKG/usr/share/applications
cp -a desktop/$PRGNAM.desktop $PKG/usr/share/applications
-mkdir -p $PKG/usr/share/mimelnk/application
-cp -a desktop/vnd.htmldoc-book.desktop $PKG/usr/share/mimelnk/application
mkdir -p $PKG/usr/share/mime/packages
cp -a desktop/htmldoc.xml $PKG/usr/share/mime/packages
-mkdir -p $PKG/usr/share/icons/hicolor/{16x16,24x24,32x32,48x48,64x64,96x96,128x128}/apps/
-cp -a desktop/htmldoc-16.png $PKG/usr/share/icons/hicolor/16x16/apps/$PRGNAM.png
-cp -a desktop/htmldoc-24.png $PKG/usr/share/icons/hicolor/24x24/apps/$PRGNAM.png
+mkdir -p $PKG/usr/share/icons/hicolor/{32x32,128x128}/apps/ $PKG/usr/share/pixmaps
cp -a desktop/htmldoc-32.png $PKG/usr/share/icons/hicolor/32x32/apps/$PRGNAM.png
-cp -a desktop/htmldoc-48.png $PKG/usr/share/icons/hicolor/48x48/apps/$PRGNAM.png
-cp -a desktop/htmldoc-64.png $PKG/usr/share/icons/hicolor/64x64/apps/$PRGNAM.png
-cp -a desktop/htmldoc-96.png $PKG/usr/share/icons/hicolor/96x96/apps/$PRGNAM.png
cp -a desktop/htmldoc-128.png $PKG/usr/share/icons/hicolor/128x128/apps/$PRGNAM.png
+cp -a desktop/htmldoc.xpm $PKG/usr/share/pixmaps/$PRGNAM.xpm
mkdir -p $PKG/usr/share/htmldoc/
cp -a fonts $PKG/usr/share/htmldoc/
cp -a data $PKG/usr/share/htmldoc/
-
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/office/htmldoc/htmldoc.info b/office/htmldoc/htmldoc.info
index 9bb5a60b8b..9ab9df907b 100644
--- a/office/htmldoc/htmldoc.info
+++ b/office/htmldoc/htmldoc.info
@@ -1,8 +1,8 @@
PRGNAM="htmldoc"
-VERSION="1.8.29"
-HOMEPAGE="http://www.msweet.org/projects.php?Z1"
-DOWNLOAD="http://www.msweet.org/files/project1/htmldoc-1.8.29-source.tar.bz2"
-MD5SUM="dd2a05e2608d4f34db13c17a6667bb5e"
+VERSION="1.8.30"
+HOMEPAGE="http://michaelrsweet.github.io/htmldoc/"
+DOWNLOAD="https://github.com/michaelrsweet/htmldoc/archive/v1.8.30/htmldoc-1.8.30.tar.gz"
+MD5SUM="93e20731015a4752a7380c3d27a191bd"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="fltk"
diff --git a/office/htmldoc/slack-desc b/office/htmldoc/slack-desc
index 0a60bdb593..a8d1134c3c 100644
--- a/office/htmldoc/slack-desc
+++ b/office/htmldoc/slack-desc
@@ -13,7 +13,7 @@ htmldoc: indexed HTML, Adobe(r) PostScript(r), or Adobe(r) Portable Document
htmldoc: Format ("PDF") files.
htmldoc: It is a product by Easy Software Products.
htmldoc:
-htmldoc: Homepage: http://www.msweet.org/projects.php?Z1
+htmldoc: Homepage: http://michaelrsweet.github.io/htmldoc/
htmldoc:
htmldoc:
htmldoc:
diff --git a/office/juffed/README b/office/juffed/README
deleted file mode 100644
index b322d42743..0000000000
--- a/office/juffed/README
+++ /dev/null
@@ -1,6 +0,0 @@
-JuffEd is a free, cross-platform text editor for programmers and
-advanced users. Has syntax highlighting for many languages, code
-folding, find/replace using plain text and regexps, code completion,
-multiple charsets and many other useful features.
-
-enca is an optional dependency (for auto language detection).
diff --git a/office/juffed/doinst.sh b/office/juffed/doinst.sh
deleted file mode 100644
index 5fb28930db..0000000000
--- a/office/juffed/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
diff --git a/office/juffed/juffed.SlackBuild b/office/juffed/juffed.SlackBuild
deleted file mode 100644
index 2b12832e30..0000000000
--- a/office/juffed/juffed.SlackBuild
+++ /dev/null
@@ -1,99 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for juffed
-
-# Copyright 2011-2017 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-
-PRGNAM=juffed
-VERSION=${VERSION:-0.10}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-DOCS="COPYING ChangeLog README"
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/${PRGNAM}-${VERSION}-1054.tar.?z*
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-mkdir -p build
-cd build
- cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_SUFFIX=$LIBDIRSUFFIX \
- -DCMAKE_BUILD_TYPE=Release ..
- make
- make install DESTDIR=$PKG
-cd ..
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/office/juffed/juffed.info b/office/juffed/juffed.info
deleted file mode 100644
index a9a8d3b42d..0000000000
--- a/office/juffed/juffed.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="juffed"
-VERSION="0.10"
-HOMEPAGE="http://juffed.com"
-DOWNLOAD="http://downloads.sourceforge.net/juffed/juffed-0.10-1054.tar.bz2"
-MD5SUM="33ca5c94fd4aedb9925e58f8f9ba9a7c"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Matteo Bernardini"
-EMAIL="ponce@slackbuilds.org"
diff --git a/office/juffed/slack-desc b/office/juffed/slack-desc
deleted file mode 100644
index ae39cf2747..0000000000
--- a/office/juffed/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-juffed: juffed (light qt editor)
-juffed:
-juffed: JuffEd is a free, cross-platform text editor for programmers and
-juffed: advanced users. Has syntax highlighting for many languages, code
-juffed: folding, find/replace using plain text and regexps, code completion,
-juffed: multiple charsets and many other useful features.
-juffed:
-juffed: homepage: http://juffed.com
-juffed:
-juffed:
-juffed:
diff --git a/office/kbgoffice/gcc6.patch b/office/kbgoffice/gcc6.patch
new file mode 100644
index 0000000000..6e2d45e572
--- /dev/null
+++ b/office/kbgoffice/gcc6.patch
@@ -0,0 +1,17 @@
+diff -Naur kbgoffice-2.1.orig/src/translator_manager.cpp kbgoffice-2.1/src/translator_manager.cpp
+--- kbgoffice-2.1.orig/src/translator_manager.cpp 2010-04-30 14:37:42.000000000 +0200
++++ kbgoffice-2.1/src/translator_manager.cpp 2017-06-01 18:10:20.308920738 +0200
+@@ -141,11 +141,11 @@
+ isDataOk = isDataOk && tr->init(tr->BG_EN, string(string(dataDir) + prop->getString("data")).c_str());
+ } else {
+ cerr << "TranslatorManager::getTestDictionaryObject - Wrong description file: " << testDictionaries[index].file << "\n";
+- return false;
++ return NULL;
+ }
+ if (!isDataOk) {
+ cerr << "TranslatorManager::getTestDictionaryObject - Problem initialazing dictionary: " << testDictionaries[index].file << "\n";
+- return false;
++ return NULL;
+ }
+ char c[16];
+ sprintf(c, "%d", level);
diff --git a/office/kbgoffice/kbgoffice.SlackBuild b/office/kbgoffice/kbgoffice.SlackBuild
index c4f4cbb1af..91069ba041 100644
--- a/office/kbgoffice/kbgoffice.SlackBuild
+++ b/office/kbgoffice/kbgoffice.SlackBuild
@@ -52,6 +52,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Thanks debian
+patch -p1 < $CWD/gcc6.patch
+
cd src
sed "s:/usr/local:/usr:" -i.orig $PRGNAM.pro
sed "s:/usr/local:/usr:" -i.orig main.cpp
diff --git a/office/referencer/referencer-lib_path.patch b/office/referencer/referencer-lib_path.patch
new file mode 100644
index 0000000000..78a1952089
--- /dev/null
+++ b/office/referencer/referencer-lib_path.patch
@@ -0,0 +1,11 @@
+--- referencer-1.2.2/src/Document.C 2014-01-27 03:43:00.000000000 +0700
++++ referencer-1.2.2_/src/Document.C 2016-11-03 16:25:00.698676538 +0700
+@@ -297,7 +297,7 @@
+
+ lib_path = lib_path->get_parent();
+ up_dir_level += "../";
+- if (lib_path == 0) {
++ if (!lib_path) {
+ doc_is_relative_to_library = false;
+ break;
+ }
diff --git a/office/referencer/referencer.SlackBuild b/office/referencer/referencer.SlackBuild
index 8d279093fd..0a3da09354 100644
--- a/office/referencer/referencer.SlackBuild
+++ b/office/referencer/referencer.SlackBuild
@@ -69,6 +69,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Fix comparison with zero - thanks archlinux
+patch -p1 < $CWD/referencer-lib_path.patch
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS -std=c++11" \
./configure \