summaryrefslogtreecommitdiffstats
path: root/network/transmission/transmission.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/transmission/transmission.SlackBuild')
-rw-r--r--network/transmission/transmission.SlackBuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/network/transmission/transmission.SlackBuild b/network/transmission/transmission.SlackBuild
index 20bd5f424e..7d975a479f 100644
--- a/network/transmission/transmission.SlackBuild
+++ b/network/transmission/transmission.SlackBuild
@@ -26,7 +26,7 @@
# Revision date: 2013/03/24
PRGNAM=transmission
-VERSION=${VERSION:-2.77}
+VERSION=${VERSION:-2.84}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -66,20 +66,24 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
mkdir -p $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-sed -i -e 's%-g -O3 -funroll-loops %%g' configure.ac
-sed -i -e 's%-ggdb3 %%g' configure.ac
+sed -i -e 's%-g -O3 -funroll-loops %%g' configure.ac || exit 1
+sed -i -e 's%-ggdb3 %%g' configure.ac || exit 1
+# http://trac.transmissionbt.com/ticket/5700
+sed -i -e '1iQMAKE_CXXFLAGS += -std=c++11' qt/qtr.pro || exit 1
# Fix hard-coded path of man file of Qt client
-sed -i "s|share/man/|man/|" qt/qtr.pro
+sed -i "s|share/man/|man/|" qt/qtr.pro || exit 1
+
+autoreconf -fi
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \