summaryrefslogtreecommitdiffstats
path: root/development/flup
diff options
context:
space:
mode:
Diffstat (limited to 'development/flup')
-rw-r--r--development/flup/README7
-rw-r--r--development/flup/flup.SlackBuild67
-rw-r--r--development/flup/flup.info10
-rw-r--r--development/flup/slack-desc16
4 files changed, 100 insertions, 0 deletions
diff --git a/development/flup/README b/development/flup/README
new file mode 100644
index 0000000000..a6ccdec006
--- /dev/null
+++ b/development/flup/README
@@ -0,0 +1,7 @@
+flup (random Python WSGI stuff)
+
+flup provides three sets of WSGI servers/gateways, which speak AJP, FastCGI, and SCGI.
+Each server comes in two flavors, a threaded and a forking version.
+
+Building this package requires pysetuptools, available from slackbuilds.org.
+
diff --git a/development/flup/flup.SlackBuild b/development/flup/flup.SlackBuild
new file mode 100644
index 0000000000..6ce78bf71b
--- /dev/null
+++ b/development/flup/flup.SlackBuild
@@ -0,0 +1,67 @@
+#!/bin/sh
+
+# Slackware build script for flup
+
+# Written by ponce <matteo.bernardini@gmail.com>
+
+PRGNAM=flup
+VERSION=${VERSION:-1.0.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ChangeLog PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/flup/flup.info b/development/flup/flup.info
new file mode 100644
index 0000000000..f00db724d0
--- /dev/null
+++ b/development/flup/flup.info
@@ -0,0 +1,10 @@
+PRGNAM="flup"
+VERSION="1.0.2"
+HOMEPAGE="http://trac.saddi.com/flup"
+DOWNLOAD="http://www.saddi.com/software/flup/dist/flup-1.0.2.tar.gz"
+MD5SUM="24dad7edc5ada31dddd49456ee8d5254"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="ponce"
+EMAIL="matteo.bernardini@gmail.com"
+APPROVED=""
diff --git a/development/flup/slack-desc b/development/flup/slack-desc
new file mode 100644
index 0000000000..8a1b5d7b42
--- /dev/null
+++ b/development/flup/slack-desc
@@ -0,0 +1,16 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+flup: flup (random Python WSGI stuff)
+flup:
+flup: flup provides three sets of WSGI servers/gateways, which speak AJP,
+flup: FastCGI, and SCGI.
+flup: Each server comes in two flavors, a threaded and a forking version.
+flup:
+flup: homepage: http://trac.saddi.com/flup
+flup: