summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README16
-rw-r--r--desktop/lxhotkey/README8
-rw-r--r--desktop/lxhotkey/lxhotkey.SlackBuild101
-rw-r--r--desktop/lxhotkey/lxhotkey.info10
-rw-r--r--desktop/lxhotkey/slack-desc19
-rw-r--r--libraries/lua-curl/README8
-rw-r--r--libraries/lua-curl/liblua-curl.pc11
-rw-r--r--libraries/lua-curl/lua-curl.SlackBuild104
-rw-r--r--libraries/lua-curl/lua-curl.info10
-rw-r--r--libraries/lua-curl/make.patch17
-rw-r--r--libraries/lua-curl/slack-desc19
-rw-r--r--multimedia/avidemux/avidemux.SlackBuild2
-rw-r--r--multimedia/avidemux/avidemux.info6
-rw-r--r--network/filezilla-old/README10
-rw-r--r--network/filezilla-old/doinst.sh14
-rw-r--r--network/filezilla-old/filezilla-old.SlackBuild121
-rw-r--r--network/filezilla-old/filezilla-old.info10
-rw-r--r--network/filezilla-old/slack-desc19
18 files changed, 501 insertions, 4 deletions
diff --git a/README b/README
index fcef7b4f67..ff2f1c4fbb 100644
--- a/README
+++ b/README
@@ -1,3 +1,19 @@
+SBo-git - slackbuilds repository for slackware-current
+- - -
+
+this is a unofficial fork of master branch from slackbuilds.org's
+git repository (http://slackbuilds.org/cgit/slackbuilds/).
+
+here I put my unofficial mods to their slackbuilds to run on
+slackware-current with sbopkg (http://www.sbopkg.org).
+
+Check https://github.com/Ponce/slackbuilds/wiki for additional informations.
+
+See https://github.com/Ponce/slackbuilds/wiki/configuring-the-current-repository-with-sbopkg
+for instructions on how to use this repository with sbopkg.
+
+original README from slackbuilds.org follows:
+---------------------------------------------
See http://slackbuilds.org/howto/ for instructions on
how to use the contents of this directory.
diff --git a/desktop/lxhotkey/README b/desktop/lxhotkey/README
new file mode 100644
index 0000000000..e8343cc1b6
--- /dev/null
+++ b/desktop/lxhotkey/README
@@ -0,0 +1,8 @@
+lxhotkey is a plugin-based shortcuts editor for window managers.
+
+openbox is an optional dependency (and ATM the only window
+manager supported).
+
+at the moment this is a command-line only application: the
+developer, Andrej N. Gritsenko, invites interested users to
+write theirselves the GUI plugins (gtk+, Qt) they need.
diff --git a/desktop/lxhotkey/lxhotkey.SlackBuild b/desktop/lxhotkey/lxhotkey.SlackBuild
new file mode 100644
index 0000000000..6337151890
--- /dev/null
+++ b/desktop/lxhotkey/lxhotkey.SlackBuild
@@ -0,0 +1,101 @@
+#!/bin/sh
+
+# Slackware build script for lxhotkey
+
+# Copyright 2016 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=lxhotkey
+VERSION=${VERSION:-20160311_4dd3520}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+DOCS="CONCEPT COPYING ChangeLog"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sh autogen.sh || true
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/lxhotkey/lxhotkey.info b/desktop/lxhotkey/lxhotkey.info
new file mode 100644
index 0000000000..6d327592a3
--- /dev/null
+++ b/desktop/lxhotkey/lxhotkey.info
@@ -0,0 +1,10 @@
+PRGNAM="lxhotkey"
+VERSION="20160311_4dd3520"
+HOMEPAGE="http://lxde.org"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/lxde/lxhotkey-20160311_4dd3520.tar.xz"
+MD5SUM="6a7fcec3c174ee3e53a0cb77748613e1"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Matteo Bernardini"
+EMAIL="ponce@slackbuilds.org"
diff --git a/desktop/lxhotkey/slack-desc b/desktop/lxhotkey/slack-desc
new file mode 100644
index 0000000000..d4845d4620
--- /dev/null
+++ b/desktop/lxhotkey/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+lxhotkey: lxhotkey (global shortcuts editor)
+lxhotkey:
+lxhotkey: lxhotkey is a plugin-based shortcuts editor for window managers.
+lxhotkey:
+lxhotkey: homepage: http://lxde.org
+lxhotkey:
+lxhotkey:
+lxhotkey:
+lxhotkey:
+lxhotkey:
+lxhotkey:
diff --git a/libraries/lua-curl/README b/libraries/lua-curl/README
new file mode 100644
index 0000000000..9a93e32abf
--- /dev/null
+++ b/libraries/lua-curl/README
@@ -0,0 +1,8 @@
+lua-curl (lua curl library)
+
+The intent of Lua-cURL is to adapt the
+ * Easy Interface
+ * Multi Interface
+ * Shared Interface
+of libcurl to the functionality of Lua (for example by using iterators
+instead of callbacks when possible).
diff --git a/libraries/lua-curl/liblua-curl.pc b/libraries/lua-curl/liblua-curl.pc
new file mode 100644
index 0000000000..4b02e4caf7
--- /dev/null
+++ b/libraries/lua-curl/liblua-curl.pc
@@ -0,0 +1,11 @@
+prefix=/usr
+exec_prefix=${prefix}
+includedir=${prefix}/include
+libdir=${exec_prefix}/lib/lua/5.1
+
+Name: liblua-curl
+Description: liblua-curl - libcurl binding to Lua
+Version: 0.3.0
+Cflags: -I${includedir}
+Libs: -L${libdir} -L/usr/lib -llua-curl -llua -lm
+
diff --git a/libraries/lua-curl/lua-curl.SlackBuild b/libraries/lua-curl/lua-curl.SlackBuild
new file mode 100644
index 0000000000..c39e255630
--- /dev/null
+++ b/libraries/lua-curl/lua-curl.SlackBuild
@@ -0,0 +1,104 @@
+#!/bin/sh
+
+# Slackware build script for lua-curl
+# Copyright Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy, 2012
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=lua-curl
+VERSION=${VERSION:-0.3.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e # Exit on most errors
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/${PRGNAM}_${VERSION}.orig.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# This is from Debian, thanks
+patch -p1 < $CWD/make.patch
+
+sed -i \
+ -e "s|usr/local/|usr|" \
+ -e "s|lua5\.1|lua|" \
+ -e "s|-Wall -O2|-Wall|" \
+ -e "s|includedir)/lua|includedir)|" \
+ -e "s|share/doc/curl|doc/curl-$VERSION|" \
+ -e "s|/lib/|/lib$LIBDIRSUFFIX|" \
+ -e "s|liblua5.1-curl|liblua-curl|" \
+ -e "s|\ \$(shell getconf LFS_CFLAGS)|${SLKCFLAGS}|" \
+ Makefile
+
+make
+install -m 0755 -D curl.so $PKG/usr/lib$LIBDIRSUFFIX/lua/5.1/lib$PRGNAM.so
+( cd $PKG/usr/lib$LIBDIRSUFFIX ; ln -s lua/5.1/lib$PRGNAM.so lib$PRGNAM.so.0 )
+
+install -m 0644 -D $CWD/lib$PRGNAM.pc $PKG/usr/lib$LIBDIRSUFFIX/pkgconfig/lib$PRGNAM.pc
+install -m 0644 -D $PRGNAM.h $PKG/usr/include/$PRGNAM.h
+sed -i "s|/lib|/lib$LIBDIRSUFFIX|" $PKG/usr/lib$LIBDIRSUFFIX/pkgconfig/lib$PRGNAM.pc
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a doc/curl.html $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/lua-curl/lua-curl.info b/libraries/lua-curl/lua-curl.info
new file mode 100644
index 0000000000..d441fcff18
--- /dev/null
+++ b/libraries/lua-curl/lua-curl.info
@@ -0,0 +1,10 @@
+PRGNAM="lua-curl"
+VERSION="0.3.0"
+HOMEPAGE="http://msva.github.com/lua-curl/"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/lua-curl_0.3.0.orig.tar.gz"
+MD5SUM="2a174d81bcfa7d663406b633195f2e89"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="lua"
+MAINTAINER="Matteo Bernardini"
+EMAIL="ponce@slackbuilds.org"
diff --git a/libraries/lua-curl/make.patch b/libraries/lua-curl/make.patch
new file mode 100644
index 0000000000..441e62e1cb
--- /dev/null
+++ b/libraries/lua-curl/make.patch
@@ -0,0 +1,17 @@
+Author: Enrico Tassi <gareuselesinge@debian.org>
+Description: fix regex to get auth options from curl.h
+Index: lua-curl-0.3.0/Makefile
+===================================================================
+--- lua-curl-0.3.0.orig/Makefile 2008-10-25 17:26:26.000000000 +0200
++++ lua-curl-0.3.0/Makefile 2012-05-30 21:57:54.000000000 +0200
+@@ -119,8 +119,8 @@
+ > curl_netrcopt.h
+
+ curl_authopt.h:$(HEADER)
+- $(H)cat $(HEADER) | grep "CURLAUTH_" | \
+- sed "s/#define *CURL/{\"/" | sed "s/ *\/\*.*\*\///" | \
++ $(H)cat $(HEADER) | grep "define *CURLAUTH_" | \
++ sed "s/#define *CURL/{\"/" | sed "s/ *\/\*.*//" | \
+ sed "s/ /\",/" | sed "s/$$/},/" > curl_authopt.h
+
+ curl_ftpauthopt.h:$(HEADER)
diff --git a/libraries/lua-curl/slack-desc b/libraries/lua-curl/slack-desc
new file mode 100644
index 0000000000..8c19468350
--- /dev/null
+++ b/libraries/lua-curl/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+lua-curl: lua-curl (lua curl library)
+lua-curl:
+lua-curl: The intent of Lua-cURL is to adapt the
+lua-curl: * Easy Interface
+lua-curl: * Multi Interface
+lua-curl: * Shared Interface
+lua-curl: of libcurl to the functionality of Lua (for example by using
+lua-curl: iterators instead of callbacks when possible).
+lua-curl:
+lua-curl: homepage: http://msva.github.com/lua-curl/
+lua-curl:
diff --git a/multimedia/avidemux/avidemux.SlackBuild b/multimedia/avidemux/avidemux.SlackBuild
index 038d121528..d15469a167 100644
--- a/multimedia/avidemux/avidemux.SlackBuild
+++ b/multimedia/avidemux/avidemux.SlackBuild
@@ -25,7 +25,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=avidemux
-VERSION=${VERSION:-2.6.11}
+VERSION=${VERSION:-2.6.12}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
diff --git a/multimedia/avidemux/avidemux.info b/multimedia/avidemux/avidemux.info
index 7f182870e4..02ce56afc4 100644
--- a/multimedia/avidemux/avidemux.info
+++ b/multimedia/avidemux/avidemux.info
@@ -1,8 +1,8 @@
PRGNAM="avidemux"
-VERSION="2.6.11"
+VERSION="2.6.12"
HOMEPAGE="http://avidemux.org"
-DOWNLOAD="http://downloads.sourceforge.net/avidemux/avidemux_2.6.11.tar.gz"
-MD5SUM="e4c753a8a2c7884270318c1951e7c00e"
+DOWNLOAD="http://downloads.sourceforge.net/avidemux/avidemux_2.6.12.tar.gz"
+MD5SUM="354d8ddf75d48d1f698786e8243ecc54"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="faac faad2 lame libdca x264 xvidcore"
diff --git a/network/filezilla-old/README b/network/filezilla-old/README
new file mode 100644
index 0000000000..79ca6a496f
--- /dev/null
+++ b/network/filezilla-old/README
@@ -0,0 +1,10 @@
+FileZilla Client is a fast and reliable cross-platform FTP, FTPS and
+SFTP client with lots of useful features and an intuitive graphical
+user interface.
+
+tinyxml is an optional dependency - to use an installed version of
+tinyxml, run the script as "TINYXML=yes ./filezilla.SlackBuild"
+otherwise, the build will use an included copy of tinyxml.
+
+*NOTE*
+this conflicts with the filezilla script: install only one of the two!
diff --git a/network/filezilla-old/doinst.sh b/network/filezilla-old/doinst.sh
new file mode 100644
index 0000000000..9830478e8c
--- /dev/null
+++ b/network/filezilla-old/doinst.sh
@@ -0,0 +1,14 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
+
diff --git a/network/filezilla-old/filezilla-old.SlackBuild b/network/filezilla-old/filezilla-old.SlackBuild
new file mode 100644
index 0000000000..d8c48759d8
--- /dev/null
+++ b/network/filezilla-old/filezilla-old.SlackBuild
@@ -0,0 +1,121 @@
+#!/bin/sh
+# Slackware build script for filezilla-old
+
+# Copyright 2007-2009 Grigorios Bouzakis <grbzks@xsmail.com>
+# Copyright 2010-2014 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2015 Matteo Bernardini <ponce@slackbuilds.org>
+# All rights reserved.
+#
+# Permission to use, copy, modify, and distribute this software for any purpose
+# with or without fee is hereby granted, provided that the above copyright
+# notice and this permission notice appear in all copies.
+#
+# THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED WARRANTIES,
+# INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND
+# FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
+# AUTHORS AND COPYRIGHT HOLDERS AND THEIR CONTRIBUTORS BE LIABLE FOR ANY
+# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
+# THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=filezilla-old
+SRCNAM=filezilla
+VERSION=${VERSION:-3.8.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README GPL.html"
+
+# Check if we have tinyxml package
+if [ "${TINYXML:-no}" = "yes" ]; then
+ tinyxml=""
+else
+ tinyxml="--with-tinyxml=builtin"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/FileZilla_${VERSION}_src.tar.bz2
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Added LDFLAGS to make it compilable, thanks to LQ
+# http://www.linuxquestions.org/questions/slackware-14/libsndfile-from-slackbuilds-org-fails-to-build-695456/
+LDFLAGS="-ldl" \
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$SRCNAM-$VERSION \
+ --disable-static \
+ --disable-manualupdatecheck \
+ --disable-autoupdatecheck \
+ --enable-locales \
+ $tinyxml \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$SRCNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$SRCNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$SRCNAM-$VERSION/$PRGNAM.SlackBuild
+mv $PKG/usr/share/$SRCNAM/docs/fzdefaults.xml.example $PKG/usr/doc/$SRCNAM-$VERSION
+# remove empty docdir
+rmdir $PKG/usr/share/$SRCNAM/docs
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/filezilla-old/filezilla-old.info b/network/filezilla-old/filezilla-old.info
new file mode 100644
index 0000000000..86a2996fba
--- /dev/null
+++ b/network/filezilla-old/filezilla-old.info
@@ -0,0 +1,10 @@
+PRGNAM="filezilla-old"
+VERSION="3.8.1"
+HOMEPAGE="http://filezilla-project.org/"
+DOWNLOAD="http://downloads.sourceforge.net/filezilla/FileZilla_3.8.1_src.tar.bz2"
+MD5SUM="b4bce64b8db97419cfefa04468afc9fb"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="wxPython"
+MAINTAINER="Matteo Bernardini"
+EMAIL="ponce@slackbuilds.org"
diff --git a/network/filezilla-old/slack-desc b/network/filezilla-old/slack-desc
new file mode 100644
index 0000000000..b61fb01016
--- /dev/null
+++ b/network/filezilla-old/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+filezilla-old: filezilla-old (the free FTP solution)
+filezilla-old:
+filezilla-old: FileZilla is a fast and reliable cross-platform FTP, FTPS, and SFTP
+filezilla-old: client with lots of useful features and an intuitive user interface.
+filezilla-old:
+filezilla-old: This is the last version still depending on wxPython (newer ones
+filezilla-old: depend on wxGTK3).
+filezilla-old:
+filezilla-old: homepage: http://filezilla-project.org
+filezilla-old:
+filezilla-old: