summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Matteo Bernardini2015-09-06 11:33:14 +0200
committer Matteo Bernardini2015-09-06 11:33:14 +0200
commitd9304ba8c566df3d4ad187919c353649084cdbc8 (patch)
tree8867a986555f0476a49fbf7fc094a55d5becd739 /python
parent277bbd069a9b13040dafc7abf299720a1c6a1a80 (diff)
downloadold.slackbuilds-current-20150906.1.tar.gz
20150906.1 global branch merge.current-20150906.1
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pygobject3/README4
-rw-r--r--python/pygobject3/pygobject3.SlackBuild8
-rw-r--r--python/pygobject3/pygobject3.info6
-rw-r--r--python/pygobject3/python3.4.patch96
-rw-r--r--python/pysetuptools/README8
-rw-r--r--python/pysetuptools/pysetuptools.SlackBuild68
-rw-r--r--python/pysetuptools/pysetuptools.info10
-rw-r--r--python/pysetuptools/slack-desc19
-rw-r--r--python/tagpy/tagpy-0.94.8-taglib-1.8_compat.patch30
-rw-r--r--python/tagpy/tagpy.SlackBuild4
-rw-r--r--python/tagpy/tagpy.info6
11 files changed, 12 insertions, 247 deletions
diff --git a/python/pygobject3/README b/python/pygobject3/README
index 40f7f4e359..fbe26d4b2a 100644
--- a/python/pygobject3/README
+++ b/python/pygobject3/README
@@ -3,5 +3,5 @@ It is a fairly complete set of bindings, it's already rather useful,
and is usable to write moderately complex programs.
Note:
-If you have python3 installed, then you will need an additional
-dependencies: gnome-common and py3cairo
+If you have python3 installed, then you will need the additional
+dependency py3cairo
diff --git a/python/pygobject3/pygobject3.SlackBuild b/python/pygobject3/pygobject3.SlackBuild
index e4a8fff48a..37114bf100 100644
--- a/python/pygobject3/pygobject3.SlackBuild
+++ b/python/pygobject3/pygobject3.SlackBuild
@@ -24,8 +24,8 @@
PRGNAM=pygobject3
SRCNAM=pygobject
-VERSION=${VERSION:-3.10.2}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-3.16.2}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -66,14 +66,12 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
if $(python3 -c 'import sys' 2>/dev/null); then
- patch -p1 < $CWD/python3.4.patch
PYTHON=python3
- ./autogen.sh
fi
CFLAGS="$SLKCFLAGS" \
diff --git a/python/pygobject3/pygobject3.info b/python/pygobject3/pygobject3.info
index 0b26e704c2..337a9d9723 100644
--- a/python/pygobject3/pygobject3.info
+++ b/python/pygobject3/pygobject3.info
@@ -1,8 +1,8 @@
PRGNAM="pygobject3"
-VERSION="3.10.2"
+VERSION="3.16.2"
HOMEPAGE="http://www.pygtk.org/"
-DOWNLOAD="http://ftp.gnome.org/pub/GNOME/sources/pygobject/3.10/pygobject-3.10.2.tar.xz"
-MD5SUM="f311155be8510df6ad8e4edf1cb463d4"
+DOWNLOAD="http://ftp.gnome.org/pub/GNOME/sources/pygobject/3.16/pygobject-3.16.2.tar.xz"
+MD5SUM="8a3720efa69dd2d520e0b21b5d9e7c19"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/python/pygobject3/python3.4.patch b/python/pygobject3/python3.4.patch
deleted file mode 100644
index c71af55b50..0000000000
--- a/python/pygobject3/python3.4.patch
+++ /dev/null
@@ -1,96 +0,0 @@
-From 2ff095ea0b0c05fbf6cc332eeadf26cfeb9e69f7 Mon Sep 17 00:00:00 2001
-From: Colin Watson <cjwatson@ubuntu.com>
-Date: Tue, 24 Dec 2013 22:19:02 +0000
-Subject: build: Avoid clash between gi/types.py and stdlib
-
-Use non-recursive make for the Python modules in gi/ to work around a
-clash between gi/types.py and the standard library's types module when
-running py-compile.
-
-https://bugzilla.gnome.org/show_bug.cgi?id=721025
-
-Signed-off-by: Martin Pitt <martinpitt@gnome.org>
-
-diff --git a/Makefile.am b/Makefile.am
-index 5051b54..58d720f 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -1,6 +1,9 @@
- ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
- AUTOMAKE_OPTIONS = 1.7
-
-+# Part of the gi subdirectory is handled with non-recursive make to avoid
-+# py-compile getting confused between gi/types.py and Python's standard
-+# types module.
- SUBDIRS = examples gi tests pygtkcompat
-
- PLATFORM_VERSION = 3.0
-@@ -49,6 +52,27 @@ MAINTAINERCLEANFILES = \
- BUILT_EXTRA_DIST = \
- ChangeLog
-
-+nobase_pyexec_PYTHON = \
-+ gi/__init__.py \
-+ gi/types.py \
-+ gi/module.py \
-+ gi/importer.py \
-+ gi/pygtkcompat.py \
-+ gi/docstring.py
-+
-+# if we build in a separate tree, we need to symlink the *.py files from the
-+# source tree; Python does not accept the extensions and modules in different
-+# paths
-+build_pylinks:
-+ for f in $(nobase_pyexec_PYTHON); do \
-+ [ -e $(builddir)/$$f ] || \
-+ $(LN_S) $(abs_srcdir)/$$f $(builddir)/$$f; \
-+ done
-+
-+all-local: build_pylinks
-+
-+check-local: build_pylinks
-+
- # pkg-config files
- pkgconfigdir = $(libdir)/pkgconfig
- pkgconfig_DATA = pygobject-$(PLATFORM_VERSION).pc
-diff --git a/gi/Makefile.am b/gi/Makefile.am
-index fc11ff8..aa91a46 100644
---- a/gi/Makefile.am
-+++ b/gi/Makefile.am
-@@ -26,14 +26,6 @@ endif
-
- pygidir = $(pyexecdir)/gi
-
--pygi_PYTHON = \
-- __init__.py \
-- types.py \
-- module.py \
-- importer.py \
-- pygtkcompat.py \
-- docstring.py
--
- pygi_LTLIBRARIES = _gi.la
-
- _gi_la_SOURCES = \
-@@ -118,16 +110,8 @@ _gi_cairo_la_LDFLAGS = \
- %$(PYTHON_SO): %.la
- $(LN_S) -f .libs/$@ $@
-
--# if we build in a separate tree, we need to symlink the *.py files from the
--# source tree; Python does not accept the extensions and modules in different
--# paths
--build_pylinks:
-- for f in $(pygi_PYTHON); do \
-- [ -e $(builddir)/$$f ] || $(LN_S) $(srcdir)/$$f $(builddir)/$$f; \
-- done
--
--all-local: $(LTLIBRARIES:.la=$(PYTHON_SO)) build_pylinks
-+all-local: $(LTLIBRARIES:.la=$(PYTHON_SO))
-
--check-local: $(LTLIBRARIES:.la=$(PYTHON_SO)) build_pylinks
-+check-local: $(LTLIBRARIES:.la=$(PYTHON_SO))
- clean-local:
- rm -f $(LTLIBRARIES:.la=$(PYTHON_SO))
---
-cgit v0.10.1
-
diff --git a/python/pysetuptools/README b/python/pysetuptools/README
deleted file mode 100644
index 1cee00b116..0000000000
--- a/python/pysetuptools/README
+++ /dev/null
@@ -1,8 +0,0 @@
-pysetuptools (a collection of enhancements to Python distutils)
-Note: the name of the source package is 'setuptools'. Since
-'setuptools' is such a generic name, this package uses the name
-'pysetuptools' to avoid any potential future conflicts. The actual
-installation paths and file names are not modified in any way.
-
-setuptools allow you to more easily build and distribute Python
-packages, especially ones that have dependencies on other packages.
diff --git a/python/pysetuptools/pysetuptools.SlackBuild b/python/pysetuptools/pysetuptools.SlackBuild
deleted file mode 100644
index 0ffafc259e..0000000000
--- a/python/pysetuptools/pysetuptools.SlackBuild
+++ /dev/null
@@ -1,68 +0,0 @@
-#!/bin/sh
-
-# Copyright 2013-2015 Audrius Kažukauskas <audrius@neutrino.lt>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=pysetuptools
-VERSION=${VERSION:-18.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM=setuptools
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=${PKG:-$TMP/package-$SRCNAM}
-OUTPUT=${OUTPUT:-/tmp}
-
-set -eu
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.txt $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pysetuptools/pysetuptools.info b/python/pysetuptools/pysetuptools.info
deleted file mode 100644
index c459daab00..0000000000
--- a/python/pysetuptools/pysetuptools.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pysetuptools"
-VERSION="18.2"
-HOMEPAGE="https://pypi.python.org/pypi/setuptools"
-DOWNLOAD="https://pypi.python.org/packages/source/s/setuptools/setuptools-18.2.tar.gz"
-MD5SUM="52b4e48939ef311d7204f8fe940764f4"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Audrius Kažukauskas"
-EMAIL="audrius@neutrino.lt"
diff --git a/python/pysetuptools/slack-desc b/python/pysetuptools/slack-desc
deleted file mode 100644
index f17cc0b281..0000000000
--- a/python/pysetuptools/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pysetuptools: pysetuptools (a collection of enhancements to Python distutils)
-pysetuptools:
-pysetuptools: Easily build, install, upgrade, and uninstall Python packages!
-pysetuptools:
-pysetuptools: Setuptools is a fully-featured, actively-maintained, and stable
-pysetuptools: library designed to facilitate packaging Python projects, where
-pysetuptools: packaging includes Python package and module definitions,
-pysetuptools: distribution package metadata, test hooks, project installation,
-pysetuptools: platform-specific details, and Python 3 support.
-pysetuptools:
-pysetuptools:
diff --git a/python/tagpy/tagpy-0.94.8-taglib-1.8_compat.patch b/python/tagpy/tagpy-0.94.8-taglib-1.8_compat.patch
deleted file mode 100644
index e6c9bef1d0..0000000000
--- a/python/tagpy/tagpy-0.94.8-taglib-1.8_compat.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-https://github.com/inducer/tagpy/commit/d0759c0ec7d24ae8d1af395a1032521eb00b4d1f
-https://github.com/inducer/tagpy/commit/813ec4f03bb4411c7ffd15dcb3974da04a3f109c
-
---- tagpy-0.94.8/src/wrapper/id3.cpp
-+++ tagpy-0.94.8/src/wrapper/id3.cpp
-@@ -79,6 +79,10 @@
- MF_OL(setVolumeAdjustment, 1, 2);
- MF_OL(setPeakVolume, 1, 2);
-
-+ #if (TAGPY_TAGLIB_HEX_VERSION >= 0x10800)
-+ MF_OL(render, 0, 1)
-+ #endif
-+
- // -------------------------------------------------------------
- // MPEG
- // -------------------------------------------------------------
-@@ -212,7 +216,12 @@
- .DEF_SIMPLE_METHOD(removeFrame)
- .DEF_SIMPLE_METHOD(removeFrames)
-
-- .DEF_SIMPLE_METHOD(render)
-+ #if (TAGPY_TAGLIB_HEX_VERSION >= 0x10800)
-+ .DEF_OVERLOADED_METHOD(render, ByteVector (cl::*)() const)
-+ .DEF_OVERLOADED_METHOD(render, ByteVector (cl::*)(int) const)
-+ #else
-+ .def("render", (ByteVector (cl::*)() const) &cl::render)
-+ #endif
- ;
- }
-
diff --git a/python/tagpy/tagpy.SlackBuild b/python/tagpy/tagpy.SlackBuild
index 7952f52f95..b4f8b61bb0 100644
--- a/python/tagpy/tagpy.SlackBuild
+++ b/python/tagpy/tagpy.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=tagpy
-VERSION=${VERSION:-0.94.8}
+VERSION=${VERSION:-2013.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -67,8 +67,6 @@ find -L . \
# Remove ez_setup. We don't want to download distribute.
sed -i -e '/distribute_setup/d' -e "s/^if.*/if False:/" aksetup_helper.py
-patch -p1 < $CWD/tagpy-0.94.8-taglib-1.8_compat.patch
-
./configure.py \
--taglib-inc-dir="/usr/include/taglib" \
--boost-python-libname="boost_python" \
diff --git a/python/tagpy/tagpy.info b/python/tagpy/tagpy.info
index 460a02c27f..1c78588cf1 100644
--- a/python/tagpy/tagpy.info
+++ b/python/tagpy/tagpy.info
@@ -1,8 +1,8 @@
PRGNAM="tagpy"
-VERSION="0.94.8"
+VERSION="2013.1"
HOMEPAGE="http://mathema.tician.de/software/tagpy"
-DOWNLOAD="http://pypi.python.org/packages/source/t/tagpy/tagpy-0.94.8.tar.gz"
-MD5SUM="6baff63318cf90b9bc5a2497a0597802"
+DOWNLOAD="https://pypi.python.org/packages/source/t/tagpy/tagpy-2013.1.tar.gz"
+MD5SUM="96cbbd8adb8a6c0b9c21851979cc7c64"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="pysetuptools"