summaryrefslogtreecommitdiffstats
path: root/python/six/six.SlackBuild
diff options
context:
space:
mode:
author Larry Hajali2013-10-28 01:14:57 +0100
committer Robby Workman2013-10-28 05:39:07 +0100
commit8d6b92b9ccd3553eac6ffa2648df5f898f3bb99a (patch)
tree7ef8368e855bf58e236688aec6e71a7087765cc3 /python/six/six.SlackBuild
parentd29439228c92391ae0293ceecf9d8e760e7462b9 (diff)
downloadold.slackbuilds-8d6b92b9ccd3553eac6ffa2648df5f898f3bb99a.tar.gz
python/six: Updated for version 1.4.1.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/six/six.SlackBuild')
-rw-r--r--python/six/six.SlackBuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/python/six/six.SlackBuild b/python/six/six.SlackBuild
index 0ccf1936b7..b7cb56668f 100644
--- a/python/six/six.SlackBuild
+++ b/python/six/six.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for six
-# Copyright 2012 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2013 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=six
-VERSION=${VERSION:-1.3.0}
+VERSION=${VERSION:-1.4.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -57,6 +57,10 @@ find . \
python setup.py install --root=$PKG
+if $(python3 -c 'import os' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true