summaryrefslogtreecommitdiffstats
path: root/system/nagios-plugins/nagios-plugins.SlackBuild
blob: cf2c8963d05af2de5a06cbed538dad30902d9421 (plain)
#!/bin/sh

# Slackware build script for nagios-plugins

# Written by Zordrak <slackbuilds@tpa.me.uk>
# Modified by Mario Preksavec <mario@slackware.hr>

PRGNAM=nagios-plugins
VERSION=${VERSION:-2.0.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i486 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

# Bail out if user or group isn't valid on your system
# For slackbuilds.org, assigned nagios uid/gid are 213/213
# See http://slackbuilds.org/uid_gid.txt
if ! grep ^nagios: /etc/group 2>&1 > /dev/null; then
    echo "  You must have a \"nagios\" group to run this script."
    echo "    # groupadd -g 213 nagios"
    exit 1
elif ! grep ^nagios: /etc/passwd 2>&1 > /dev/null; then
    echo "  You must have a \"nagios\" user to run this script."
    echo "    # useradd -u 213 -g nagios -d /usr/libexec/nagios -s /bin/false nagios"
    exit 1
fi

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \;

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --libexecdir=/usr/libexec/nagios \
  --sysconfdir=/etc/nagios \
  --localstatedir=/var \
  --build=$ARCH-slackware-linux \
  --with-nagios-user=nagios \
  --with-nagios-group=nagios \
  --without-world-permissions

make
make install DESTDIR=$PKG

# Put the contrib plugins dir in along with the official plugins
# otherwise most people will never realise they exist
#cp -a contrib $PKG/usr/libexec/nagios/.

find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

chown -R root.nagios $PKG/usr/libexec/nagios
chmod u+s $PKG/usr/libexec/nagios/check_{icmp,dhcp};

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
  README REQUIREMENTS ACKNOWLEDGEMENTS AUTHORS CODING COPYING \
  ChangeLog FAQ INSTALL LEGAL NEWS SUPPORT THANKS \
    $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}