summaryrefslogtreecommitdiffstats
path: root/system/multipath-tools/multipath-tools.SlackBuild
blob: feb20d6fe256ccd8b702e381642abf1246189877 (plain)
#!/bin/bash
# Copyright 2014,2018 Nikos Yotis <nikos.giotis@gmail.com>
# Copyright 2021  Mario Preksavec, Zagreb, Croatia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

# 20220413 bkw: Modified by SlackBuilds.org, BUILD=3:
# - fix broken symlink in doc dir.
# - strip binaries and libraries.

# 20220321 bkw: Modified by SlackBuilds.org, BUILD=2:
# - fix 32-bit build.
# - fix path to kpart_id script in udev rules.

# 22-Oct-2018
# Updated for version 0.7.8

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=multipath-tools
VERSION=${VERSION:-0.8.7}
BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) export ARCH=i586 ;;
    arm*) export ARCH=arm ;;
       *) export ARCH=$( uname -m ) ;;
  esac
fi

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION

# Patch for slackware compatibility
cat $CWD/0002-multipathd-add-ncurses-to-linker.patch | patch -p0 --verbose

chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \+ -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+

# Build
cd $TMP/$PRGNAM-$VERSION
CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" make
make install DESTDIR=$PKG

find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

# Move everything in place
mkdir -p $PKG/lib
mv $PKG/usr/lib/udev $PKG/lib/udev
rmdir $PKG/usr/lib &>/dev/null || true
sed -i 's,/usr/lib/udev,/lib/udev,' $PKG/lib/udev/rules.d/11-dm-mpath.rules

# Manpages
mv $PKG/usr/share/man $PKG/usr/
rm -rf $PKG/usr/share
gzip -9 $PKG/usr/man/man*/*

# init script
mkdir -p $PKG/etc/rc.d
cat $CWD/rc.multipathd.new > $PKG/etc/rc.d/rc.multipathd.new
chmod 755 $PKG/etc/rc.d/rc.multipathd.new

# default config
cat $CWD/multipath.conf.new > $PKG/etc/multipath.conf.new
chmod 644 $PKG/etc/multipath.conf.new

# Docs
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
  LICENSES COPYING README.alua README.md \
  $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

# 20220413 bkw: note: *never* use "cp -a" to copy files from $CWD to
# the package. if the file happens not to be owned by root, you end up
# with bad ownership in the package!
cat $CWD/README.SLACKWARE > $PKG/usr/doc/$PRGNAM-$VERSION/README.SLACKWARE

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE