summaryrefslogtreecommitdiffstats
path: root/system/lz4/lz4.SlackBuild
blob: 184b0ee71b4ff086dcfec4b0916bc194da01662d (plain)
#!/bin/sh

# Slackware build script for lz4

# Written by B. Watson (yalhcru@gmail.com)

# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.

# 20170122 bkw: update for 1.7.5

PRGNAM=lz4
VERSION=${VERSION:-1.7.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/v$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
 -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

make \
  CFLAGS="$SLKCFLAGS" \
  PREFIX=/usr \
  LIBDIR=/usr/lib$LIBDIRSUFFIX \
  MANDIR=/usr/man/man1 \
  DESTDIR=$PKG \
  default install

# Don't ship the static lib.
rm -f $PKG/usr/lib$LIBDIRSUFFIX/*.a

# lz4 and lz4c aren't quite identical: lz4c has "legacy arguments".
# The man page doesn't document them, but lz4c --help does.
# Not sure if it's really useful to keep both binaries around, but
# until I know for sure, I'll keep them both.
### rm -f $PKG/usr/bin/lz4c $PKG/usr/man/man1/lz4c.1

find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done

DOCDIR=$PKG/usr/doc/$PRGNAM-$VERSION
mkdir -p $DOCDIR
cp -a NEWS README* examples $DOCDIR

# the library is BSD licensed, but the programs are GPL.
cat programs/COPYING > $DOCDIR/LICENSE.programs.txt
cat lib/LICENSE > $DOCDIR/LICENSE.lib.txt

cat $CWD/$PRGNAM.SlackBuild > $DOCDIR/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}