summaryrefslogtreecommitdiffstats
path: root/system/graveman/graveman.SlackBuild
blob: c7df3d3a7055c33e392cdd22926090f2c51525f7 (plain)
#!/bin/sh

# Slackware build script for Graveman

# Written by Chess Griffin <chess at chessgriffin dot com>

# Note:  the developer's source code version is numbered
# with a dash at the end, e.g. 0.3.12-5, which can throw
# off the package building process.  This SlackBuild fixes
# the problem by using a SRCVER variable for the source
# version and a VERSION variable for the local version.
# Essentially, this changes the dash to a period.
# Be sure to change both variables accordingly when used
# with a new version of Graveman.  Thanks to Eric Hameleers
# for the fix.

PRGNAM=graveman
SRCVER=0.3.12-5 	# this is the developer's source version
VERSION=0.3.12.5	# this is local version
ARCH=${ARCH:-i486}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
fi

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP || exit 1
rm -rf $PRGNAM-$SRCVER
tar -xzvf $CWD/$PRGNAM-$SRCVER.tar.gz || exit 1
cd $PRGNAM-$SRCVER || exit 1
chown -R root:root .
chmod -R u+w,go+r-w,a-s .

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --sysconfdir=/etc \
  --localstatedir=/var \
  || exit 1

make || exit 1
make install-strip DESTDIR=$PKG || exit 1

if [ -d $PKG/usr/man ]; then
( cd $PKG/usr/man
  find . -type f -exec gzip -9 {} \;
  for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
)
fi

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS COPYING Changelog NEWS README* THANKS TRANSLATE-HOWTO.fr \
  $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n -p $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz