summaryrefslogtreecommitdiffstats
path: root/system/ZoneMinder/ZoneMinder.SlackBuild
blob: 4c9acc1aad48c7dc870a2ff1967713b88d66a84e (plain)
#!/bin/sh

# Slackware build script for ZoneMinder

# Copyright 2014 Gene Baxter <GenoBob@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=ZoneMinder
VERSION=${VERSION:-1.27.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

CAMBOZOLA_VERSION=${CAMBOZOLA_VERSION:-0.935}  # Java streaming client
JSCALENDAR_VERSION=${JSCALENDAR_VERSION:-1.0} # Calendar plugin (use 1.0 here)
DOCOWN=${DOCOWN:-apache}
DOCGRP=${DOCGRP:-apache}
DOCROOT=${DOCROOT:-"/srv/httpd/htdocs/zm"}
CGIROOT=${CGIROOT:-"/srv/httpd/cgi-bin"}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i486 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/v$VERSION.tar.gz
cd $PRGNAM-$VERSION
tar xvf $CWD/cambozola-$CAMBOZOLA_VERSION.tar.gz
unzip $CWD/jscalendar-$JSCALENDAR_VERSION.zip
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

# Regenerate files for automake/autoconf.
./bootstrap.sh

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS -D__STDC_CONSTANT_MACROS" \
./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --sysconfdir=/etc/zm \
  --localstatedir=/var \
  --mandir=/usr/man \
  --build=$ARCH-slackware-linux \
  --with-libarch=lib${LIBDIRSUFFIX} \
  --with-mysql=/usr \
  --with-ffmpeg=/usr \
  --with-webdir=$DOCROOT \
  --with-cgidir=$CGIROOT \
  --with-webuser=$DOCOWN \
  --with-webgroup=$DOCGRP \
  --disable-debug \
  --enable-mmap=yes

make
make install DESTDIR=$PKG INSTALLDIRS=vendor INSTALLVENDORMAN3DIR=/usr/man/man3

# Strip binaries
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

# Compress manpages
find $PKG/usr/man -type f -exec gzip -9 {} \;

# Remove junk files and dirs
find $PKG -name perllocal.pod \
  -o -name ".packlist" \
  -o -name "*.bs" \
  | xargs rm -f || true

find $PKG/usr -depth -type d -empty -delete || true

mkdir -p $PKG/var/{log,lock/subsys}
install -d -o $DOCOWN -g $DOCGRP $PKG/var/log/zm

for DIR in events images sound; do
  install -d -o $DOCOWN -g $DOCGRP $PKG$DOCROOT/$DIR
done

# Install logrotate script
mkdir -p $PKG/etc/logrotate.d/
cat $CWD/zm_logrotate > $PKG/etc/logrotate.d/zm.new

# Install apache config
sed "s%@DOCROOT@%$DOCROOT%" $CWD/zm_apache.conf > $PKG/etc/zm/zm_apache.conf.new

# Do not clobber the config file
mv $PKG/etc/zm/zm.conf $PKG/etc/zm/zm.conf.new

# Install startup script
install -D -m 644 scripts/zm $PKG/etc/rc.d/rc.zm.new

# Install cambozola
install -m 644 cambozola-$CAMBOZOLA_VERSION/dist/cambozola.jar $PKG$DOCROOT

# Install jscalendar
mkdir -p $PKG$DOCROOT/tools/jscalendar
cp -Rp jscalendar-$JSCALENDAR_VERSION/* $PKG$DOCROOT/tools/jscalendar

mkdir -p $PKG/usr/share/$PRGNAM/db
cp -a db/zm_create.sql db/zm_update-*.sql $PKG/usr/share/$PRGNAM/db

# Copy documentation
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS ChangeLog INSTALL NEWS TODO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cat $CWD/README.SLACKWARE > $PKG/usr/doc/$PRGNAM-$VERSION/README.SLACKWARE


mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}