summaryrefslogtreecommitdiffstats
path: root/perl/perl-GD/perl-GD.SlackBuild
blob: a27cbe63aa61a9fc4a048d1fb085b4b670095495 (plain)
#!/bin/sh

# Slackware build script for perl-GD

# Written by B. Watson (yalhcru@gmail.com)

# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.

PRGNAM=perl-GD
VERSION=${VERSION:-2.56}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

SRCNAM="GD"

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

# the "perl Makefile.PL" method fails to build the shared library,
# probably it's obsolete and the author forgot to remove Makefile.PL
# from the tarball.

# you might notice this in the build log:
# ** WARNING: found gd.h header file in /usr/X11R6/include/gd.h
# this isn't a real issue, since on Slackware /usr/X11R6/include
# is just a symlink to /usr/include.

# one of the tests in t/GD.t fails because it's using freetype to render
# text into images, then comparing pixel-for-pixel to reference images. it
# fails because the results are not pixel-exact, probably due to the
# author using a different version of freetype to generate the reference
# images... or even just different compiler flags used for building
# freetype... or even something as dumb as using a different CPU whose
# floating point returns slightly different results from the author's.
# if you modify the test code so it writes its result to a PNG file and
# then eyeball that next to the reference one (t/test_data/t07/7-00.png),
# you'll be hard-pressed to see the difference... but it's there.

# this patch disables just this one test:
patch -p1 < $CWD/no_ttf_test.diff

perl Build.PL
./Build
./Build test
./Build install \
  --prefix /usr \
  --installdirs vendor \
  --destdir $PKG \
  --install_path bindoc=/usr/man/man1 \
  --install_path libdoc=/usr/man/man3

# this stuff gets erroneously installed to /usr/bin:
rm -f $PKG/usr/bin/README $PKG/usr/bin/*.PLS

# and this doesn't belong in the package either:
rm -f $PKG/usr/man/man?/*.PLS.*

find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done

find $PKG -name perllocal.pod \
  -o -name ".packlist" \
  -o -name "*.bs" \
  | xargs rm -f

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README* ChangeLog LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}