summaryrefslogtreecommitdiffstats
path: root/office/coolreader/coolreader.SlackBuild
blob: 8bd2795b74ab83a333aac37efb8b525e55ca5c12 (plain)
#!/bin/sh

# Slackware build script for CoolReader

# Copyright 2011-2012  Fridrich von Stauffenberg <email removed>
# Copyright 2020       B. Watson <yalhcru@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

# 20201019 bkw:
# - update for v3.2.49, new homepage.
# - allow for building qt4, qt5, wx UIs.
# - replace useless/inaccurate man page with our own.

# 20200126 bkw, BUILD=2:
# - take over maintenance
# - i486 => i586
# - make .desktop file validate
# - fix documetn => document typo
# - add supported filetypes to README and slack-desc
# - save/load settings (.ini file) to ~/.cr3, not /usr/share/cr3.

PRGNAM=coolreader
VERSION=${VERSION:-3.2.49}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-cr$VERSION
tar xvf $CWD/$PRGNAM-cr$VERSION.tar.gz
cd $PRGNAM-cr$VERSION
find -L .  -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
        \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+

# Use bundled libunibreak, ours is too old (3.0).
# Use bundled fribidi, Pat's is too old (0.19.7).
sed -i -e '/find_package(libunibreak)/d' \
       -e '/find_package(FriBidi)/d' \
       CMakeLists.txt

# Install the docs in the right place for Slackware.
sed -i "s,share/doc/cr3,doc/$PRGNAM-$VERSION," cr3qt/CMakeLists.txt

# The settings patch for qt4 was made by loading cr3qt/src/settings.ui
# into Qt Designer and saving it again. Needed because upstream's
# using a different (older?) version of qt4.

GUI=${GUI:-QT}
GUI="$( echo $GUI | tr a-z A-Z )"
case "$GUI" in
  QT)  UI=Qt4
       patch -p1 < $CWD/qt4_settings_ui.diff ;;
  QT5) UI=Qt5 ;;
  WX)  # Either 2.8.x or 3.0.x works, be specific in the slack-desc.
       UI="wxWidgets $( wx-config --version | cut -d. -f1,2)" ;;
  *)   echo "*** Unsupported GUI '$GUI', use one of: QT QT5 WX"
       exit 1 ;;
esac

echo "=== Building $UI GUI"

mkdir -p build
cd build
  cmake \
    -D USE_UNRAR=1 \
    -D CMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
    -D CMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
    -D CMAKE_INSTALL_PREFIX=/usr \
    -D LIB_SUFFIX=${LIBDIRSUFFIX} \
    -D CMAKE_BUILD_TYPE=Release \
    -D MAX_IMAGE_SCALE_MUL=2 \
    -D DOC_DATA_COMPRESSION_LEVEL=3 \
    -D DOC_BUFFER_SIZE=0x1400000 \
    -D GUI=$GUI ..
  make VERBOSE=1
  make install/strip DESTDIR=$PKG
cd ..

# Upstream's man page doesn't document all the options, and incorrectly
# refers to the (nonexistent) info page. It's also hardcoded to install
# to /usr/share/man.
rm -rf $PKG/usr/share/man
mkdir -p $PKG/usr/man/man1
gzip -9c < $CWD/cr3.1 > $PKG/usr/man/man1/cr3.1.gz

# Tired of having to remember the binary's called something other than
# the package and source name.
ln -s cr3 $PKG/usr/bin/$PRGNAM
ln -s cr3.1.gz $PKG/usr/man/man1/$PRGNAM.1.gz

# This dir already exists with GUI=QT or QT5, but not WX.
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README.md cr3gui/COPYING $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
sed "s,@UI@,$UI," $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}