summaryrefslogtreecommitdiffstats
path: root/network/znc/znc.SlackBuild
blob: 35f6d3a507a283b99ea4ce104dc14b53b6f5066a (plain)
#!/bin/sh

# Slackware build script for ZNC

# Copyright 2007-2009  Sean Donner (sean.donner at gmail dot com)
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=znc
VERSION=0.076
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

ZNC_USER=${ZNC_USER:-znc}
WITH_SSL=${WITH_SSL:-yes}
WITH_IPV6=${WITH_IPV6:-yes}
WITH_CARES=${WITH_CARES:-no}

# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i486 ;;
    arm*) ARCH=arm ;;
    # Unless $ARCH is already set, use uname -m for all other archs:
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i486" ]; then
   SLKCFLAGS="-O2 -march=i486 -mtune=i686"
   LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
   SLKCFLAGS="-O2 -march=i686 -mtune=i686"
   LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
   SLKCFLAGS="-O2 -fPIC"
   LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

# Bail if user and/or group isn't valid on your system
# uid=219 is suggested to avoid conflicts with other SBo packages,
# but it's your call: http://slackbuilds.org/uid_gid.txt
if ! grep -q "^$ZNC_USER:" /etc/passwd; then
  echo "  You must have a $ZNC_USR user to run this script. "
  echo "  Something like this should suffice for most systems: "
  echo "      # useradd -u 219 -g 99 -c \"ZNC User\" -d /etc/znc $ZNC_USER"
  exit 1
fi

set -e

rm -rf $PKG 
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .

if [ "$WITH_SSL" != "yes" ]; then
  do_openssl="--without-openssl"
else
  do_openssl="--with-openssl"
fi

if [ "$WITH_IPV6" != "yes" ]; then
  do_ipv6="--disable-ipv6"
else
  do_ipv6="--enable-ipv6"
fi

if [ "$WITH_CARES" != "yes" ]; then
  do_cares="--disable-c-ares"
else
  do_cares="--enable-c-ares"
fi

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --sysconfdir=/etc \
  --localstatedir=/var \
  --mandir=/usr/man \
  --build=$ARCH-slackware-linux \
  --enable-extra \
  $do_openssl \
  $do_ipv6 \
  $do_cares

make all
make install DESTDIR=$PKG

( cd $PKG
  find . -exec file {} + | sed -n '/ELF.*executable\|shared object/s/:.*$//p' | \
  	xargs strip --strip-unneeded 2> /dev/null || true
  find . -exec file {} + | sed -n '/current ar archive/s/:.*$//p' | \
  	xargs strip --strip-debug 2> /dev/null || true
)

# Change the ownership of the configuration directory
mkdir -p $PKG/etc/znc
chown -R $ZNC_USER $PKG/etc/znc

# Install an init script 
mkdir -p $PKG/etc/rc.d
sed -e "s/_ZNC_USER_/$ZNC_USER/g" -e "s/_VERSION_/$VERSION/g" $CWD/rc.znc \
  > $PKG/etc/rc.d/rc.znc.new

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
  AUTHORS LICENSE* README \
  $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
sed s/_ZNC_USER_/$ZNC_USER/g $CWD/README.SBo > \
  $PKG/usr/doc/$PRGNAM-$VERSION/README.SBo

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}