summaryrefslogtreecommitdiffstats
path: root/network/transmission/transmission.SlackBuild
blob: 274d96b02cda6f11d69a5ea0f9ce4448449def10 (plain)
#!/bin/sh
# Slackware build script for transmission

# Copyright 2007 Vasilis Papavasileiou <el03020 at mail dot ntua dot gr>
# Copyright 2008-2011 Iskar Enev <iskar.enev[@]gmail.com>
# Copyright 2011-2013 Niels Horn, Rio de Janeiro, Brazil
# Copyright 2015 B. Watson <yalhcru@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

# 20180207 bkw: update for v2.93

# 20180116 bkw: security fix, BUILD=2. See:
#               https://github.com/transmission/transmission/pull/468
#               Thanks to Freenode user lord_ for pointing this out.

# 20180611 bkw: update for v2.94

# 20170621 bkw: fix build on -current.

# 20150204 bkw: allow user to disable the various components.
# By default, all are enabled. We can disable transmission-gtk,
# transmission-qt, transmission-cli, and/or transmission-daemon.
# But disabling them all is no good.

PRGNAM=transmission
VERSION=${VERSION:-2.94}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

DOCUMENTATION="AUTHORS COPYING INSTALL NEWS README"

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

GTK="${GTK:-yes}"
QT="${QT:-yes}"
CLI="${CLI:-yes}"
DAEMON="${DAEMON:-yes}"

if [ "$GTK" != "yes" -a "$QT" != "yes" -a "$CLI" != "yes" -a "$DAEMON" != "yes" ]; then
  cat <<EOF 1>&2
Can't build transmission with everything disabled, at least one of
GTK QT CLI DAEMON must be 'yes'.
EOF
  exit 1
fi

# anything but lowercase "yes" is considered a no!
[ "$GTK" != "yes" ] && GTKOPT="no" || GTKOPT="yes"
[ "$CLI" != "yes" ] && CLIOPT="dis" || CLIOPT="en"
[ "$DAEMON" != "yes" ] && DAEMOPT="dis" || DAEMOPT="en"

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
mkdir -p $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

# Fix CVE-2018-5702 for transmission-2.92. Patch came from:
# https://github.com/transmission/transmission/files/1624507/transmission-fix-dns-rebinding-vuln.patch.txt
#patch -p1 < $CWD/transmission-fix-dns-rebinding-vuln.diff
# Not needed for >= 2.93

sed -i -e 's%-g -O3 -funroll-loops %%g' configure.ac
sed -i -e 's%-ggdb3 %%g' configure.ac

# fix for -current (does no harm on stable). ref:
# https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c13b5e88c6e9c7bd2698d844cb5ed127ed809f7e
rm -f m4/glib-gettext.m4

# Thanks Larry Hajali
autoreconf -ivf

CC=gcc CXX=g++ \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --sysconfdir=/etc \
  --localstatedir=/var \
  --mandir=/usr/man \
  --disable-static \
  --verbose \
  --with-gtk=$GTKOPT \
  --${CLIOPT}able-cli \
  --${DAEMOPT}able-daemon \
  --build=$ARCH-slackware-linux \
  --host=$ARCH-slackware-linux

# build daemon, GTK and cli client (unless disabled)
make
make install DESTDIR=$PKG

if [ "$QT" = "yes" ]; then
  # build the Qt client (transmission-qt) unless disabled
  # Fix hard-coded path of man file of Qt client
  sed -i "s|share/man/|man/|" qt/qtr.pro

  # Needed when using Qt4
  # https://trac.transmissionbt.com/ticket/5700#comment:2
  echo "QMAKE_CXXFLAGS += -std=c++11" >> qt/qtr.pro

  cd $TMP/$PRGNAM-$VERSION/qt
    qmake \
      QMAKE_CXXFLAGS+="$SLKCFLAGS" \
      QMAKE_CFLAGS+="$SLKCFLAGS" \
      qtr.pro
    sed -i -e 's% -g % %g' Makefile
    make
    INSTALL_ROOT=$PKG/usr make install

  mkdir -p $PKG/usr/share/applications $PKG/usr/share/pixmaps
  install -m644 transmission-qt.desktop $PKG/usr/share/applications/transmission-qt.desktop
  install -m644 icons/transmission.png  $PKG/usr/share/pixmaps/transmission-qt.png
  cd -
fi

find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCUMENTATION $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
sed "s,@opts@,GTK=$GTK QT=$QT CLI=$CLI DAEMON=$DAEMON," $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}