summaryrefslogtreecommitdiffstats
path: root/network/nicotine+/nicotine+.SlackBuild
blob: 11928f1f5a9653f5cb3ffb854572fe6e908ea16e (plain)
#!/bin/sh
# Slackware build script for nicotine+
# Written by Iskar Enev <iskar.enev[@]gmail.com>
# Modified by the SlackBuilds.org project

PRGNAM=nicotine+
VERSION=1.2.14
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i486 ;;
    arm*) ARCH=arm ;;
    # Unless $ARCH is already set, use uname -m for all other archs:
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar -xjvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
 \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \;

python setup.py build
python setup.py install --root $PKG

find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

mv $PKG/usr/share/man $PKG/usr
( cd $PKG/usr/man
  find . -type f -exec gzip -9 {} \;
  for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
)

( cd $PKG/usr/bin
  ln -s nicotine.py nicotine
)

# Contains duplicates from site-package so removing it
rm -rf $PKG/usr/pynicotine

# Let's use the larger icon to ensure proper scaling
sed -i 's%Icon=nicotine-plus-32px.png%Icon=nicotine-plus-96px.png%' \
  $PKG/usr/share/applications/nicotine.desktop

# Let's put these icons and such in a subdirectory of their own instead of
# spamming /usr/share/pixmaps with all sorts of stuff
rm $PKG/usr/share/pixmaps/*
mkdir -p $PKG/usr/share/pixmaps/nicotine
cp -a files/*.png img/*.png img/*.ico img/*.xcf img/README \
  $PKG/usr/share/pixmaps/nicotine
cp -a $PKG/usr/share/pixmaps/nicotine/nicotine-plus-96px.png $PKG/usr/share/pixmaps

mkdir -p $PKG/usr/doc
cp -a COPYING MANIFEST PKG-INFO $PKG/usr/share/nicotine/documentation
mv $PKG/usr/share/nicotine/documentation $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/nicotine-plus.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}