summaryrefslogtreecommitdiffstats
path: root/network/gui-ufw/gui-ufw.SlackBuild
blob: 306d92af576ef15d70e2129a01adf1357115bae4 (plain)
#!/bin/bash

# Slackware build script for gui-ufw

# Copyright 2018, 2019 Skaendo <skaendo@linuxmail.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

# 20220315 bkw: Modified by SlackBuilds.org, BUILD=2:
# - fix broken wrapper scripts that prevented the app from starting
#   on 32-bit Slackware, or after a python3 upgrade, or if the user
#   uses runlevel 3.
# - fix repeated builds (we were missing "rm -rf $PRGNAM-$VERSION").

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=gui-ufw
VERSION=${VERSION:-19.10.0}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

# 20220315 bkw: No compiled code here, and setup.py knows about
# lib64 directories already.

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
mkdir $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \+ -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+

python3 setup.py install --prefix=/usr --root=$PKG

# 20220315 bkw: upstream's wrapper scripts are broken in multiple ways:
# - hardcoded (wrong) path to gufw.py
# - relies on loginctl, meaning it'll never work for users who
#   use runlevel 3 (console login + startx)
# - the xhost stuff unconditionally removes localuser:root access
#   when gufw exits, even if the user put it there before the
#   script was run
# Replace gufw and gufw-pkexec with something that actually works.
rm -f $PKG/usr/bin/*
install -oroot -groot -m0755 $CWD/gufw.wrapper $PKG/usr/bin/gufw

# Move the manpage to a sane directory.
mv $PKG/usr/share/man $PKG/usr

# Clean up some duplicates
rm -rf $PKG/usr/share/doc

gzip -9 $PKG/usr/man/man*/*

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING* README \
  $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE