summaryrefslogtreecommitdiffstats
path: root/network/copy/copy.SlackBuild
blob: 6fbbe143434c6328ef89c6c7ae16979694cbd565 (plain)
#!/bin/sh

# Slackware build script for Copy
#
# Ryan P.C. McQuen | Everett, WA | ryan.q@linux.com

# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 3 of the License, or
# (at your option) any later version, with the following exception:
# the text of the GPL license may be omitted.

# This program is distributed in the hope that it will be useful, but
# without any warranty; without even the implied warranty of
# merchantability or fitness for a particular purpose. Compiling,
# interpreting, executing or merely reading the text of the program
# may result in lapses of consciousness and/or very being, up to and
# including the end of all existence and the Universe as we know it.
# See the GNU General Public License for more details.

# You may have received a copy of the GNU General Public License along
# with this program (most likely, a file named COPYING).  If not, see
# <http://www.gnu.org/licenses/>.

PRGNAM=copy
SRCNAM=copy_agent
DSKNAM=CopyAgent
VERSION=${VERSION:-1.47.0410}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=x86 ;;
    arm*) ARCH=armv6h ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

TARBALL=$SRCNAM-$VERSION.tgz
TARBALL_ROOT=$PRGNAM

# Set LIBDIRSUFFIX and TARBALL.
if [ "$ARCH" = "x86_64" ]; then
  LIBDIRSUFFIX="64"
else
  LIBDIRSUFFIX=""
fi

set -eu

rm -rf $PKG
mkdir -pv $TMP $PKG $OUTPUT
cd $TMP
rm -rf "$TARBALL_ROOT"
tar -xvf "$CWD/$TARBALL"
cd "$TARBALL_ROOT"
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

mkdir -pv $PKG/opt/$PRGNAM
mkdir -pv $PKG/usr/share/applications/
cp -a * $PKG/opt/$PRGNAM

find $PKG -print0 | xargs -0 file | \
  grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

mkdir -p $PKG/usr/bin
ln -sf /opt/$PRGNAM/$ARCH/CopyAgent $PKG/usr/bin
ln -sf /opt/$PRGNAM/$ARCH/CopyCmd $PKG/usr/bin
ln -sf /opt/$PRGNAM/$ARCH/CopyConsole $PKG/usr/bin

## fix qt incompatibilities by using
## the libraries already on the system
## -current users must relink these on all qt updates
ln -sf /usr/lib$LIBDIRSUFFIX/qt/lib/libQt* $PKG/opt/$PRGNAM/$ARCH/

install -m644 $CWD/$DSKNAM.desktop $PKG/usr/share/applications/

mkdir -p $PKG/usr/share/icons
install -m644 $CWD/copy-client.png $PKG/usr/share/icons

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}