summaryrefslogtreecommitdiffstats
path: root/network/claws-mail-extra-plugins/claws-mail-extra-plugins.SlackBuild
blob: 307d20d51654921d2193bdea2eb7474b20a26185 (plain)
#!/bin/sh

# SlackBuild Script to build the extra plugins for claws mail

# Copyright (c) 2007, Timothy Pollard
# 
# All rights reserved.
# 
# Redistribution and use in source and binary forms, with or without modification,
# are permitted provided that the following conditions are met:
# 
# * Redistributions of source code must retain the above copyright notice,
#   this list of conditions and the following disclaimer.
# * Redistributions in binary form must reproduce the above copyright
#   notice, this list of conditions and the following disclaimer in the
#   documentation and/or other materials provided with the distribution.
# 
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
# TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
# PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
# LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

# Modified by Robby Workman <rworkman@slackbuilds.org>

PRGNAM=claws-mail-extra-plugins
VERSION=3.3.1
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

# This is a *complete* list of available plugins
#PLUGIN_LIST="acpi_notifier att_remover attachwarner cachesaver \
#  fetchinfo-plugin gtkhtml2_viewer mailmbox newmail notification_plugin \
#  pdf_viewer perl_plugin rssyl smime spam_report synce_plugin vcalendar"

# This is the list of plugins that the script will build by default
# Note that the synce_plugin is not included, as it requires two other 
# library dependencies that are not available at SlackBuilds.org
PLUGIN_LIST="acpi_notifier att_remover attachwarner cachesaver \
  fetchinfo-plugin gtkhtml2_viewer mailmbox newmail notification_plugin \
  pdf_viewer perl_plugin rssyl smime spam_report vcalendar"

if [ "$ARCH" = "i486" ]; then
    SLKCFLAGS="-O2 -march=i486 -mtune=i486"
elif [ "$ARCH" = "i686" ]; then
    SLKCFLAGS="-O2 -march=i686 -mtune=i686"
fi

set -e 		# Exit on most errors

rm -rf $PKG $TMP/$PRGNAM-$VERSION
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp README $PKG/usr/doc/$PRGNAM-$VERSION

for plugin in $(echo $PLUGIN_LIST) ; do
  ( echo "Building plugin: $plugin"
    cd ./$plugin-*  || exit 1

    CFLAGS="$SLKCFLAGS" \
    ./configure \
    --prefix=/usr \
    --sysconfdir=/etc \
    --localstatedir=/var \
    --disable-static || exit 1

    make || exit 1
    make install DESTDIR=$PKG || exit 1

    mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/$plugin
    for docfile in AUTHORS COPYING ChangeLog INSTALL NEWS README TODO ; do
      [ -e $docfile ] && cp -a $docfile $PKG/usr/doc/$PRGNAM-$VERSION/$plugin
    done

    echo "Finished building plugin: $plugin"
  ) || exit 1
done

cp $CWD/$PRGNAM.SlackBuild $PKG/usr/doc/$PRGNAM-$VERSION/
find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

( cd $PKG
  find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : \
         | xargs strip -- strip-unneeded 2> /dev/null
  find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : \
         | xargs strip -- strip-unneeded 2> /dev/null
)

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD.tgz