summaryrefslogtreecommitdiffstats
path: root/multimedia/spotify64/spotify64.SlackBuild
blob: 28399a40ccf29a948ebfa27c14e2c5e94b3fb716 (plain)
#!/bin/sh
# Slackware build script for spotify64

# Ryan P.C. McQuen | Everett, WA | ryan.q@linux.com

# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version, with the following exception:
# the text of the GPL license may be omitted.

# This program is distributed in the hope that it will be useful, but
# without any warranty; without even the implied warranty of
# merchantability or fitness for a particular purpose. Compiling,
# interpreting, executing or merely reading the text of the program
# may result in lapses of consciousness and/or very being, up to and
# including the end of all existence and the Universe as we know it.
# See the GNU General Public License for more details.

# You may have received a copy of the GNU General Public License along
# with this program (most likely, a file named COPYING).  If not, see
# <http://www.gnu.org/licenses/>.

PRGNAM=spotify64
SRCNAM=spotify
VERSION=${VERSION:-0.9.17.8.gd06432d.31}
SHORTVER=`echo $VERSION | cut -d. -f1-3`
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

case "$(uname -m)" in
  x86_64) DEBARCH="amd64" ; LIBDIRSUFFIX="64" ; ARCH=x86_64 ;;
    *) echo "Package for $(uname -m) architecture is not available." ; exit 1 ;;
esac

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -eu

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $PKG
ar -p $CWD/${SRCNAM}-client-${SHORTVER}_${VERSION}-1_${DEBARCH}.deb data.tar.xz | tar Jxv
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

## fixes udev1 dependency
ln -sf /usr/lib${LIBDIRSUFFIX}/libudev.so $PKG/opt/$SRCNAM/$SRCNAM-client/Data/libudev.so.1

## we don't need the symlink,
## we have udev issues to fix  ;^)
rm $PKG/usr/bin/$SRCNAM

## we make our own script since
## we have to set the lib path
cat <<EOT > $PKG/usr/bin/$SRCNAM
#!/bin/sh
## fix libudev issue
LD_LIBRARY_PATH=/opt/$SRCNAM/$SRCNAM-client/Data/ /opt/$SRCNAM/$SRCNAM-client/$SRCNAM
EOT
chmod 755 $PKG/usr/bin/$SRCNAM

rm $PKG/opt/$SRCNAM/$SRCNAM-client/$SRCNAM.desktop
mkdir -p $PKG/usr/share/applications/
cat $CWD/$SRCNAM.desktop > $PKG/usr/share/applications/$SRCNAM.desktop

mv $PKG/usr/share/doc $PKG/usr
mv $PKG/usr/doc/$SRCNAM-client-$SHORTVER $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-${VERSION}-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}