summaryrefslogtreecommitdiffstats
path: root/multimedia/flash-player-plugin/flash-player-plugin.SlackBuild
blob: c67d15a577606df066f5f6c89143300d28b8ff47 (plain)
#!/bin/sh

# Copyright 2010  Robby Workman, Northport, Alabama, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=flash-player-plugin
VERSION=10.2_d161
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

SRC_VERSION=091510

case "$( uname -m )" in
  i?86) ARCH=i386 ;;
  arm*) ARCH=arm ;;
     *) ARCH=$( uname -m ) ;;
esac

if [ "$ARCH" = "x86_64" ]; then
  LIBDIRSUFFIX="64"
  SRC_ARCH=64bit
elif [ "$ARCH" = "i386" ]; then
  LIBDIRSUFFIX=""
  SRC_ARCH=32bit
else
  printf "\n\n$ARCH is unsupported...\n"
  exit 1
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}  

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP

tar xf $CWD/flashplayer_square_p1_${SRC_ARCH}_linux_${SRC_VERSION}.tar.gz

# Check to make sure we're packaging the same version that this script
# was written to handle:
_REALVERS=$(strings libflashplayer.so | grep -e "^Shockwave Flash [.\d+]*" | sed -e "s/Shockwave Flash //g")
if [ ! "$(echo $_REALVERS | tr ' ' _)" = "$(echo $VERSION)" ]; then
  echo
  echo "This build script was written for a different version of the"
  echo "flash plugin than you have downloaded.  This is probably due"
  echo "to Adobe changing the upstream tarball - they don't have"
  echo "versioned tarballs - and it's almost certainly nothing to be"
  echo "concerned about.  However, if this package doesn't build or"
  echo "work as expected, contact the SlackBuilds.org project on our"
  echo "users mailing list."
  echo
  sleep 5
fi

mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/mozilla/plugins
install -m 0755 libflashplayer.so $PKG/usr/lib${LIBDIRSUFFIX}/mozilla/plugins

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n -p $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}