summaryrefslogtreecommitdiffstats
path: root/multimedia/cinelerra/cinelerra.SlackBuild
blob: e7f8c552f01fff5022a6765f17704f78e2380f1e (plain)
#!/bin/sh

# Slackware build script for cinelerra

# Written by Giovanne Castro <giovannefc@ig.com.br>

PRGNAM=cinelerra
VERSION=${VERSION:-cv_einar_cf708d7f}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i486 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

if [ "$ARCH" = "x86_64" ]; then
  mmx=""
else
  mmx="--enable-mmx"
fi

# --external-ffmpeg works only with version 0.5.x of FFMPEG.
# Not compatible with FFPEG 0.6 series, in this case, cinelerra
# will be compiled with internal ffmpeg (includes in the package).
# Uses "yes" or "no". Default: "no".
EXTERNALFFMPEG=${EXTERNALFFMPEG:-no}

if [ "$EXTERNALFFMPEG" = "no" ]; then
  externalffmpeg=""
elif [ "$EXTERNALFFMPEG" = "yes" ]; then
  externalffmpeg="--with-external-ffmpeg"
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM
chown -R root:root .
find . \
 \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \;

# Patch for libpng 1.4.x and po_POTFILES.in (Fixed deleted files)
patch -p1 < $CWD/shapewipe-libpng14.patch
patch -p1 < $CWD/Fix_POTFILES.patch

./autogen.sh
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --sysconfdir=/etc \
  --localstatedir=/var \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --with-plugindir=/usr/lib${LIBDIRSUFFIX}/cinelerra \
  --disable-static \
  --mandir=/usr/man \
  --with-pic \
  --with-x \
  --enable-opengl \
  --with-buildinfo=git_cv_einar_$VERSION \
  --build=$ARCH-slackware-linux \
  $externalffmpeg \
  $mmx

make
make install DESTDIR=$PKG

find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
  AUTHORS COPYING ChangeLog INSTALL LICENSE NEWS README* TODO \
  $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

# Delete ffmpeg headers and libraries to prevent conflicts with ffmpeg package
if [ "$EXTERNALFFMPEG" = "no" ]; then
  rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig
  rm -rf $PKG/usr/include/libav{codec,device,format,util}
fi

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}