summaryrefslogtreecommitdiffstats
path: root/misc/grc/grc.SlackBuild
blob: 8aaf9b6546cc3c01f7dd8c25f51fcf7e3591475d (plain)
#!/bin/bash
#
# Slackware build script for grc.
#
# Copyright 2015-2018  Edinaldo P. Silva, Rio de Janeiro, Brazil.
# Copyright 2020 Ricardo J. Barberis
# Copyright 2023 B. Watson
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

# 20240208 bkw: BUILD=2
# - add fix from Debian, for 'ip addr' highlighting. for some reason,
#   they call this version 1.13.1, though upstream has not released
#   such a version.

# 20230806 bkw:
# - take over maintenance.
# - ARCH=noarch since it's just python.
# - update for v1.13.
# - expand README, fix the fish command so it actually works.
# - add profile script for (t)csh.
# - preserve_perms for profile.d scripts in doinst.sh.

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM="grc"
VERSION=${VERSION:-1.13}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
ARCH=noarch

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L .  -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
        \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +

patch -p1 < $CWD/ipaddr.diff

# Hardcoded man path sucks...
sed -i 's,/share/man,/man,' install.sh

./install.sh $PKG/usr $PKG
gzip -9 $PKG/usr/man/man*/*

install -Dm644 _grc $PKG/usr/share/zsh/site-functions/_grc

mv $PKG/etc/grc.conf $PKG/etc/grc.conf.new
mv $PKG/etc/profile.d/grc.sh $PKG/etc/profile.d/grc.sh.new

# Might as well include this, so enabling for bourne-like shells
# will be a one-step process (chmod +x /etc/profile.d/grc.sh).
mkdir -p $PKG/etc/default
echo "GRC_ALIASES=true" > $PKG/etc/default/grc.new

# 20230806 bkw: (t)csh support. For shiggles.
install -m0644 -oroot -groot $CWD/grc.csh $PKG/etc/profile.d/grc.csh.new

PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
mkdir -p $PKGDOC
cp -r contrib debian/{changelog,copyright} CREDITS README* *.txt TODO $PKGDOC
cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE