summaryrefslogtreecommitdiffstats
path: root/libraries/wxGTK/wxGTK.SlackBuild
blob: 04248ed5f205203fcf8e66b699a6c62377d66e34 (plain)
#!/bin/sh

# Slackware build script for wxGTK

# Written by Chess Griffin <chess at chessgriffin dot com>
# with lots of key help from Eric Hameleers and the SBo
# admins.  Thanks for all the help!
# Update for version 2.6.3 by Marc-Andre Moreau

# Modified by the SlackBuilds.org project

PRGNAM=wxGTK	
VERSION=2.6.3	
ARCH=${ARCH:-i486}
BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

# If you don't want a unicode-enabled build, change to NO or
# pass UNICODE=NO ./wxGTK.SlackBuild when building
UNICODE=${UNICODE:-YES}

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
fi

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP || exit 1
rm -rf $PRGNAM-$VERSION
tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
cd $PRGNAM-$VERSION || exit 1
chown -R root:root .
chmod -R u+w,go+r-w,a-s .

# Set unicode flag as desired by UNICODE variable
if [ "$UNICODE" = "YES" ]; then
  _do_unicode="en"
elif [ "$UNICODE" = "NO" ]; then
  _do_unicode="dis"
fi

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --sysconfdir=/etc \
  --enable-shared \
  --${_do_unicode}able-unicode \
  || exit 1

make || exit 1
make install DESTDIR=$PKG || exit 1

( cd $PKG
  find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
  find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
)

# Now let's fix the broken symlink created by the package
cd $PKG/usr/bin
  rm wx-config
  if [ "$UNICODE" = "YES" ]; then
    ln -s /usr/lib/wx/config/gtk2-unicode-release-2.6 wx-config
  elif [ "$UNICODE" = "NO" ]; then
    ln -s /usr/lib/wx/config/gtk2-ansi-release-2.6 wx-config
  fi
cd -

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CHANGES-GTK.txt CHANGES.txt COPYING.LIB INSTALL.txt LICENCE.txt README-GTK.txt README.txt TODO.txt \
  $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz