summaryrefslogtreecommitdiffstats
path: root/libraries/librhtv/librhtv.SlackBuild
blob: a5c0f381a0b45236825b386682fc2bc8a687f394 (plain)
#!/bin/sh

# Slackware build script for <librhtv>

# Copyright 2019, Zhu Qun-Ying
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=librhtv
VERSION=${VERSION:-2.2.2}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
mkdir $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
rpm2cpio < $CWD/$PRGNAM-$VERSION-1.fc28.src.rpm | cpio -imdv

tar xvf tvision-$VERSION.tar.gz
cd tvision
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
# remove mentioning of local building directory information in
# include/tv/configtv.h
sed -i -e "s/\/tmp\/SBo\/librhtv-$VERSION\/tvision\/include//g" \
       -e "s/\/tmp\/SBo\/librhtv-$VERSION\/tvision\/makes//g" \
       -e "s/\/tmp\/SBo\/librhtv-$VERSION\/tvision//g" include/tv/configtv.h

# need to modified the libdir in the Makefile
if [ "$ARCH" = "x86_64" ]; then
    sed -i -s 's/prefix)\/lib/prefix)\/lib64/g' Makefile
fi
make
make install prefix=$PKG/usr

strip --strip-unneeded $PKG/usr/lib$LIBDIRSUFFIX/librhtv.so.$VERSION \
$PKG/usr/bin/*

mkdir -p $PKG/usr/lib$LIBDIRSUFFIX/pkgconfig
if [ "$ARCH" != "x86_64" ]; then
    sed -s 's/lib64/lib/g' $CWD/librhtv.pc > $PKG/usr/lib/pkgconfig/librhtv.pc
else
    install -m 0644 $CWD/librhtv.pc  $PKG/usr/lib64/pkgconfig
fi

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a doc/*.txt doc/*.html readme.txt examples $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

find $PKG/usr/doc/$PRGNAM-$VERSION/examples -name ".cvsignore" | xargs rm

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}