summaryrefslogtreecommitdiffstats
path: root/graphics/baires/baires.SlackBuild
blob: 60cfc2bca219de6f030965e0d0aab15e87f07bf2 (plain)
#!/bin/bash

# Slackware build script for Baires
# Copyright 2012, Bojan Popovic, Belgrade, Serbia, <email removed>
# Now maintained by B. Watson <yalhcru@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

# 20211217 bkw: BUILD=2
# - fix -current build (by porting to qt5).
# - new-style icons.

# Modified by B. Watson, 20141208:
# - took over as maintainer
# - use archive.org URLs in .info file
# - install shipped HTML docs, have the Help option use
#   them instead of upstream's site (which no longer exists)
# - use 128px icon instead of 48px
# - make .desktop file validate
# - minor script cleanups

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=baires
VERSION=${VERSION:-1.2r1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}


if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

DOCS="CHANGELOG LICENSE documentation/*.html snapshots"

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM
tar xvf $CWD/$PRGNAM.tar.?z*
cd $PRGNAM
chown -R root:root .
find -L .  -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
        \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+

# 20211217 bkw: turned out to be fairly trivial to port this to qt5.

# The patch also removes the 'Ruski' option from the Language
# dropdown, since the Cyrillic characters in the source somehow got
# mojibaked into a bunch of question marks. What appears to have
# happened: the original translations.cpp file was either UTF-8, or
# a mix of ISO-8859-1 and whatever Cyrillic encoding the translator
# used... and someone converted it to ISO-8859-1 (on purpose, or by
# using a crappy editor that silently converted it). The only ways to
# fix this would be to either find an older version of baires from
# before the corruption (unlikely, since upstream's site is long
# dead) or find someone who knows Russian and is willing to redo the
# translation.

patch -p1 < $CWD/qt5.diff

# use locally installed copies of HTML docs, since upstream's site has
# gone away.
sed -i \
  "s,http://www.beli.ws/apps/baires/help/,file:///usr/doc/$PRGNAM-$VERSION/," \
  mainwindow.cpp

# the HTML docs have fully qualified URLs for images, use local copies
# for these, too.
ICON=/usr/share/icons/hicolor/64x64/apps/$PRGNAM.png
SNAPS=/usr/doc/$PRGNAM-$VERSION/snapshots
sed -i \
  -e "s,http://www\.beli\.ws/images/baires-64\.png,file://$ICON," \
  -e "s,http://www\.beli\.ws/images/\(baires._..\.png\),file://$SNAPS/\1," \
  documentation/*.html

qmake-qt5 QMAKE_CFLAGS="$SLKCFLAGS" \
	QMAKE_CXXFLAGS="$SLKCFLAGS" \
	$PRGNAM.pro

make

mkdir -p $PKG/usr/bin $PKG/usr/share/pixmaps $PKG/usr/share/applications
install -s -m 755 $PRGNAM $PKG/usr/bin

for px in 32 48 64 128; do
  size=${px}x${px}
  dir=$PKG/usr/share/icons/hicolor/$size/apps
  mkdir -p $dir
  cp -a icons/$PRGNAM-$px.png $dir/$PRGNAM.png
done

ln -s ../icons/hicolor/48x48/apps/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png

# Get rid of deprecated & nonstandard keys from .desktop, for
# desktop-file-validate.
sed -e '/^Encoding/d' \
    -e '/^X-SuSE/d' \
    -e '/^Icon/s,=.*,=baires,' \
    $PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE