summaryrefslogtreecommitdiffstats
path: root/games/typhoon_2001/typhoon_2001.SlackBuild
blob: 8f970d5feffbe86b6743ff3e91afa13bf31b0dc7 (plain)
#!/bin/sh

# SlackBuild script for Typhoon 2001
# Written by B. Watson (yalhcru@gmail.com)

# This game is binary only and works like a DOS game (it expects to
# be run from its own directory), so for system-wide installation it
# needs a symlink forest in the user's home directory... except the
# typhoon.cfg needs to be a real file and be writable by the user.
# (it will be created the first time the game is run).
PRGNAM=typhoon_2001
VERSION=r3992
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

rm -fr $TMP/$PRGNAM $PKG $TMP/$PRGNAM-$VERSION
mkdir -p $TMP $PKG $OUTPUT

# Grr. tarball doesn't contain a top-level dir, it pollutes the
# current dir...
mkdir $TMP/$PRGNAM || exit 1
cd $TMP/$PRGNAM || exit 1
tar xvf $CWD/${PRGNAM}_$VERSION.tar.gz || exit 1

# Don't trust the ownership/permissions...
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
chmod 755 typhoon

# OK, put everything where it goes in a proper Slack package...
mkdir -p $PKG/usr/share/games/$PRGNAM \
			$PKG/usr/libexec \
			$PKG/usr/doc/$PRGNAM-$VERSION \
			$PKG/install \
			$PKG/usr/bin

mv readme_linux.txt $PKG/usr/doc/$PRGNAM-$VERSION
mv typhoon $PKG/usr/libexec
mv * $PKG/usr/share/games/$PRGNAM

cat $CWD/slack-desc >$PKG/install/slack-desc
install -m 0755 $CWD/$PRGNAM $PKG/usr/bin/$PRGNAM

chmod 755 $PKG/usr/bin/$PRGNAM

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD.tgz