summaryrefslogtreecommitdiffstats
path: root/games/stuntrally/stuntrally.SlackBuild
blob: bcec5d68ee0b3622ba05ef64bbea5ed8e4d14dbe (plain)
#!/bin/bash

# Slackware build script for stuntrally

# Copyright 2017-2020 Jeremy Hansen <jebrhansen+SBo -at- gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

# 20220501 bkw: Modified by SlackBuilds.org, BUILD=2:
# - only package the correct set of binaries/libraries (32-bit or 64-bit).
# - make .desktop files validate (mostly).

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=stuntrally
SRCNAM=StuntRally
VERSION=${VERSION:-2.6}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

case "$ARCH" in
  i?86|x86_64) ;;
  *) echo "ARCH=$ARCH unsupported" ;;
esac

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION-linux64
tar xvf $CWD/$SRCNAM-$VERSION-linux.tar.gz
cd $SRCNAM-$VERSION-linux64
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \+ -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
cd ..
mkdir -p $PKG/{opt/$PRGNAM/,usr/bin/}
cp -r StuntRally-$VERSION-linux64/* $PKG/opt/$PRGNAM/

cd $PKG
ln -s /opt/$PRGNAM/stuntrally usr/bin/
ln -s /opt/$PRGNAM/sr-editor usr/bin/
mv opt/$PRGNAM/share usr/
rm -f $PKG/opt/$PRGNAM/lib/{32,64}/libstdc++.so.6

# 20220501 bkw: x86_64 packages don't need the 32-bit exe and libs,
# i?86 packages don't need the 64-bit ones. saves a bit of disk space.
if [ "$ARCH" = "x86_64" ]; then
  rm -rf $PKG/opt/$PRGNAM/bin/*_x86 $PKG/opt/$PRGNAM/lib/32
else
  rm -rf $PKG/opt/$PRGNAM/bin/*_x86_64 $PKG/opt/$PRGNAM/lib/64
fi

find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

# 20220501 bkw: pacify desktop-file-validate somewhat.
sed -i -e '/^Categories/s,Application;,,' \
       $PKG/usr/share/applications/*.desktop

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a opt/$PRGNAM/License.txt opt/$PRGNAM/Readme.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE