summaryrefslogtreecommitdiffstats
path: root/games/steem/steem.SlackBuild
blob: 1ec6aca05c84e26068d9b59743a0b720e47b62a6 (plain)
#!/bin/sh

# Slackware build script for steem

# Written by B. Watson (yalhcru@gmail.com)

# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.

# 20180123 bkw:
# - BUILD=3
# - 4 years now and open source steem still fails to build.
# - Allow building a (fake) x86_64 package on 64-bit, since the
#   binary is fully static and runs fine on 64-bit. This is
#   how it should have been from day one, sorry about that.

# 20141112 bkw:
# - binary in /usr/games, not /usr/bin
# - rewrite man page as pod, move to man6
# - get giant steem.pdf.xz out of the SBo tarball, move to my host
# This will be the last submission for the old binary-only
# steem for linux. Will be working on building the open source
# steem in the near future.

PRGNAM=steem
VERSION=${VERSION:-3.2}
BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}

# Binary-only package, ARCH is a lie, but set it to
# what tools like sbopkg will expect.
if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -e

SRCVER=${VERSION/./_}

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
mkdir $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
tar xvf $CWD/x${PRGNAM}_v${SRCVER}-i486.tar.gz
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \;

mkdir -p $PKG/usr/games $PKG/usr/share/$PRGNAM/patches \
         $PKG/usr/libexec $PKG/usr/share/$PRGNAM/tos \
         $PKG/usr/man/man6 $PKG/usr/doc/$PRGNAM-$VERSION

# binary's already stripped
install -m0755 $PRGNAM $PKG/usr/libexec/$PRGNAM.bin
install -m0755 $CWD/$PRGNAM.sh $PKG/usr/games/$PRGNAM

cp -r patches/* $PKG/usr/share/$PRGNAM/patches

unzip -LL $CWD/tos_uk.zip
if [ -e $CWD/tos_us.zip ]; then
  unzip -LL $CWD/tos_us.zip
fi

cp tos*.img $PKG/usr/share/$PRGNAM/tos

cp -a *.txt FAQ README win32.help $PRGNAM.new $PKG/usr/doc/$PRGNAM-$VERSION

# CRLF's suck..
sed -i 's/\r//g' $PKG/usr/doc/$PRGNAM-$VERSION/*

cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

# Man page created from the --help output
gzip -9c < $CWD/$PRGNAM.6 > $PKG/usr/man/man6/$PRGNAM.6.gz

# pdf doc was created by running chm2pdf on the chm help downloaded from
# the original site.
xzcat $CWD/$PRGNAM.pdf.xz > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.pdf

# icon converted from the windows icon using wrestool on steem.exe
mkdir -p $PKG/usr/share/pixmaps $PKG/usr/share/applications
cat $CWD/$PRGNAM.png > $PKG/usr/share/pixmaps/$PRGNAM.png

# .desktop written for this build
cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}