summaryrefslogtreecommitdiffstats
path: root/games/mednafen/mednafen.SlackBuild
blob: 83c30a2c8e7e3fc6fb8c880f0e6c4b7ed97f646e (plain)
#!/bin/sh
# Slackware build script for mednafen

# Copyright 2008 - 2014  Heinz Wiesinger, Amsterdam, The Netherlands
# Copyright 2014 - 2016  Ryan P.C. McQuen | Everett, WA
# Copyright 2017 - 2019  Johannes Schoepfer, Germany
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=mednafen
VERSION=${VERSION:-1.22.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM
tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

# sanitize build flags, thanks to the gentoo folks
sed \
  -e '/-fno-fast-math/d' \
  -e '/-fno-unsafe-math-optimizations/d' \
  -e '/-fno-aggressive-loop-optimizations/d' \
  -e '/-fno-ipa-icf/d' \
  -e '/-fno-printf-return-value/d' \
  -e '/-fomit-frame-pointer/d' \
  -e '/-fno-pic/d' \
  -e '/-fno-pie/d' \
  -e '/-fno-PIC/d' \
  -e '/-fno-PIE/d' \
  -e '/-nopie/d' \
  -e '/-no-pie/d' \
  -e '/-fno-stack-protector/d' \
  -e '/-fno-stack-protector-all/d' \
  -e '/-fno-stack-protector-strong/d' \
  -e '/-mtune=haswell/d' \
  -i configure.ac

# This warning is not true at least on x86_64
if [ "$ARCH" = "x86_64" ]; then
  sed -e '/Compiling with position-independent code generation enabled is not recommended, for performance reasons/d' \
    -i src/types.h
fi

# provide buildtime pkgconfig file, which is missing in lzo-2.09
cat << EOF > lzo2.pc
prefix=/usr
exec_prefix=\${prefix}
includedir=\${prefix}/include
libdir=/usr/lib$LIBDIRSUFFIX
Name: lzo2
Version: 2.09
Description: LZO - a real-time data compression library
URL: http://www.oberhumer.com/opensource/lzo/
Cflags: -I\${includedir}/lzo
Libs: -L\${libdir} -llzo2
EOF

autoreconf
PKG_CONFIG_PATH=. \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --libdir=/usr/lib$LIBDIRSUFFIX \
  --sysconfdir=/etc \
  --localstatedir=/var \
  --mandir=/usr/man \
  --disable-debugger \
  --with-external-lzo \
  --build=$ARCH-slackware-linux

make
make install-strip DESTDIR=$PKG

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -ar ABOUT-NLS ChangeLog COPYING Documentation INSTALL \
  README{,.DOS,.PORTING} TODO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
rm -f $PKG/usr/doc/$PRGNAM-$VERSION/Documentation/Makefile.*

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}