summaryrefslogtreecommitdiffstats
path: root/games/liquidwar6/liquidwar6.SlackBuild
blob: 899015681ad7dcaeecd686d0fc151f07e1e9c437 (plain)
#!/bin/sh

# Slackware build script for liquidwar6

# Written by B. Watson (yalhcru@gmail.com)

PRGNAM=liquidwar6
VERSION=${VERSION:-0.0.9beta}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

SHORTNAM=${PRGNAM/[0-9]*/}

# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i486 ;;
    arm*) ARCH=arm ;;
    # Unless $ARCH is already set, use uname -m for all other archs:
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R a-s,u+w,go+r-w .

# liquidwar really ought to be using pkg-config to get the correct -l
# flags for sqlite3, but it doesn't.
patch -p1 < $CWD/sqlite_libdl.diff

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --bindir=/usr/games \
  --sysconfdir=/etc \
  --localstatedir=/var \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --infodir=/usr/info \
  --enable-shared \
  --disable-static \
  --mandir=/usr/man

make
make install-strip DESTDIR=$PKG

# /usr/lib/ is hard-coded in too many places where --libdir gets
# ignored. On 64-bit arches, the libs should live in /usr/lib64,
# but the game will always look in /usr/lib
if [ -n "${LIBDIRSUFFIX}" ]; then
  ( cd $PKG/usr/lib
    mv $PRGNAM-$VERSION ../lib${LIBDIRSUFFIX}
    ln -s ../lib${LIBDIRSUFFIX}/$PRGNAM-$VERSION $PRGNAM-$VERSION
  )
fi

gzip $PKG/usr/man/man6/$PRGNAM.6
( cd $PKG/usr/man/man6 ; ln -s $PRGNAM.6.gz $SHORTNAM.6.gz )
( cd $PKG/usr/games ; ln -s $PRGNAM $SHORTNAM )

# PNG icon converted from data/net/htdocs/favicon.ico
mkdir -p $PKG/usr/share/pixmaps
cat $CWD/$PRGNAM.png > $PKG/usr/share/pixmaps/$PRGNAM.png

mkdir -p $PKG/usr/share/applications
cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop

rm -f $PKG/usr/info/dir
gzip -9 $PKG/usr/info/*

# The package docs are just a skeleton, completely useless
# (the real docs are the info pages, although they're not all that
# useful either)
rm -rf $PKG/usr/share/doc

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README NEWS ChangeLog COPYING AUTHORS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

# If the extra-maps source is found, install it
# (do this last so we can edit the slack-desc in place)
if [ -r $CWD/$PRGNAM-extra-maps-$VERSION.tar.gz ]; then
  ( cd $TMP
    tar xvf $CWD/$PRGNAM-extra-maps-$VERSION.tar.gz
    mkdir -p $PKG/usr/share/$PRGNAM-$VERSION/map/extra
    cp -r $PRGNAM-extra-maps-$VERSION/map/* \
       $PKG/usr/share/$PRGNAM-$VERSION/map/extra
  )
  sed -i -e '18s/:/: This package includes the extra game maps./' \
    $PKG/install/slack-desc
fi

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}