summaryrefslogtreecommitdiffstats
path: root/games/fortune-farscape/fortune-farscape.SlackBuild
blob: b8474bace0ef0d027e6ba6fddf0e725ffb9d4600 (plain)
#!/bin/bash

# Slackware build script for fortune-farscape

# Written by B. Watson (yalhcru@gmail.com)

# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.

# 20191224 bkw: I'm my own upstream on this one. The fortune file was
# made by scraping wikiquotes, then hand-massaging the data into the
# format fortune(6) wants and fixing a few typos/etc. Also added a
# few quotes from episodes that didn't have any quotes on wikiquote,
# specifically "Beware of Dog", "Incubator", "I-Yensch, You-Yensch",
# "Twice Shy".

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=fortune-farscape
VERSION=${VERSION:-20191224}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
ARCH=noarch

# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -e

FDIR=$PKG/usr/share/games/fortunes
rm -rf $PKG
mkdir -p $TMP $FDIR $OUTPUT
cd $FDIR
xzcat $CWD/$PRGNAM-$VERSION.xz > farscape
strfile farscape

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE